java.lang.UnsatisfiedLinkError

no jnind4j in java.library.path

Samebug tips1

When installing an APK, it automatically extracts the libraries of the right arch type and has them available for System.loadLibrary. But, if you're trying to load a non-standard library, the installer won't know your app has 32bit native code.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4474

  • via GitHub by HuichuanLiu
    , 6 months ago
    no jnind4j in java.library.path
  • no jnind4j in java.library.path
  • via GitHub by agibsonccc
    , 1 year ago
    no jnind4j in java.library.path
  • Stack trace

    • java.lang.UnsatisfiedLinkError: no jnind4j in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1860) at java.lang.Runtime.loadLibrary0(Runtime.java:845) at java.lang.System.loadLibrary(System.java:1084) at org.bytedeco.javacpp.Loader.loadLibrary(Loader.java:726) at org.bytedeco.javacpp.Loader.load(Loader.java:501) at org.nd4j.nativeblas.NativeOps.<clinit>(NativeOps.java:31) at org.nd4j.linalg.cpu.nativecpu.ops.NativeOpExecutioner.<init>(NativeOpExecutioner.java:33) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:525) at java.lang.Class.newInstance0(Class.java:374) at java.lang.Class.newInstance(Class.java:327) at org.nd4j.linalg.factory.Nd4j.initWithBackend(Nd4j.java:5093) at org.nd4j.linalg.factory.Nd4j.initContext(Nd4j.java:5021) at org.nd4j.linalg.factory.Nd4j.<clinit>(Nd4j.java:169) at org.deeplearning4j.nn.conf.NeuralNetConfiguration$Builder.seed(NeuralNetConfiguration.java:487) at org.deeplearning4j.examples.convolution.LenetMnistExample.main(LenetMnistExample.java:45) Caused by: java.lang.UnsatisfiedLinkError: /tmp/javacpp8128481090622289/libjnind4j.so: /usr/lib64/libgomp.so.1.0.0: version `GOMP_4.0' not found (required by /tmp/javacpp8128481090622289/libnd4j.so) at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1939) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1864) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1825) at java.lang.Runtime.load0(Runtime.java:792) at java.lang.System.load(System.java:1059) at org.bytedeco.javacpp.Loader.loadLibrary(Loader.java:709) ... 14 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Once, 2 weeks ago
    Unknown user
    Once, 7 months ago
    Unknown user
    Once, 8 months ago
    134 times, 8 months ago
    83 more bugmates