oracle.oai.agent.common.AgentRuntimeException: Specified attribute (ItemRef) does not exist in Data Type (IVRS_PROTOCOL_SETUP3_OAI_V1_P:OAI/V1). Please use iStudio to check your mappings. It is possible that you have a mapping which uses this attribute even though you have deleted it from the Data Type. It is also possible that you have changed information in iStudio which the Adapter has not picked up yet because the Adapter has metadata caching turned on, in which case, you should Push Metadata from iStudio to this adapter.

Oracle Community | 435488 | 1 decade ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    Interconnect not generating XML messages with attributes

    Oracle Community | 1 decade ago | 435488
    oracle.oai.agent.common.AgentRuntimeException: Specified attribute (ItemRef) does not exist in Data Type (IVRS_PROTOCOL_SETUP3_OAI_V1_P:OAI/V1). Please use iStudio to check your mappings. It is possible that you have a mapping which uses this attribute even though you have deleted it from the Data Type. It is also possible that you have changed information in iStudio which the Adapter has not picked up yet because the Adapter has metadata caching turned on, in which case, you should Push Metadata from iStudio to this adapter.
  2. 0

    How Use Arrays on 9iAS Integration

    Oracle Community | 1 decade ago | 137783
    oracle.oai.agent.common.AgentRuntimeException: El atributo especificado (CHSPDet ail) no existe en el tipo de dato (TableTest_CreateData_IN_OAI_V1_R:OAI/V1). Uti lice iStudio para comprobar las asignaciones. Puede que tenga asignaciones que u tilizan este atributo aunque lo haya suprimido del tipo de dato. TambiÚn puede q ue haya cambiado la informaci¾n de iStudio que el adaptador no haya leÝdo todavÝ a porque tenga activado el almacenamiento de metadatos en cachÚ. En ese caso, de berß transferir los metadatos desde iStudio a este adaptador.

    Root Cause Analysis

    1. oracle.oai.agent.common.AgentRuntimeException

      Specified attribute (ItemRef) does not exist in Data Type (IVRS_PROTOCOL_SETUP3_OAI_V1_P:OAI/V1). Please use iStudio to check your mappings. It is possible that you have a mapping which uses this attribute even though you have deleted it from the Data Type. It is also possible that you have changed information in iStudio which the Adapter has not picked up yet because the Adapter has metadata caching turned on, in which case, you should Push Metadata from iStudio to this adapter.

      at oracle.oai.agent.common.AttributeObjectImpl.getAttributeInfo()
    2. oracle.oai.agent
      DBMessageReader.run
      1. oracle.oai.agent.common.AttributeObjectImpl.getAttributeInfo(AttributeObjectImpl.java:72)
      2. oracle.oai.agent.adapter.database.DBMessageReader.readDBMessageUsingNewOaiSchema(DBMessageReader.java:578)
      3. oracle.oai.agent.adapter.database.DBMessageReader.sendDBMessage(DBMessageReader.java:648)
      4. oracle.oai.agent.adapter.database.DBMessageReader.run(DBMessageReader.java:243)
      4 frames
    3. Java RT
      Thread.run
      1. java.lang.Thread.run(Thread.java:534)
      1 frame