java.lang.NoClassDefFoundError: org/apache/woden/resolver/URIResolver at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:60) at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:60)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

A few things cause this exception:
1) Check if you have all jars and if they're in the correct path.
2) Your classpath might be broken, you can define it in the command line with java -cp yourClassPath or at your IDE if you're using one.

,

you can change your scala version to 2.11.11

Solutions on the web

via com.br by Unknown author, 1 year ago
org/apache/woden/resolver/URIResolver at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:60) at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:60)
via apache.org by Unknown author, 2 years ago
org/apache/woden/resolver/URIResolver at org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDeployer.java:65)
java.lang.ClassNotFoundException: org.apache.woden.resolver.URIResolver
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.apache.axis2.deployment.repository.util.DeploymentFileData.deploy(DeploymentFileData.java:136)
at org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:659)
at org.apache.axis2.deployment.RepositoryListener.loadClassPathModules(RepositoryListener.java:209)
at org.apache.axis2.deployment.RepositoryListener.init2(RepositoryListener.java:70)
at org.apache.axis2.deployment.RepositoryListener.(RepositoryListener.java:63)
at org.apache.axis2.deployment.DeploymentEngine.loadFromClassPath(DeploymentEngine.java:164)
at org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:135)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:64)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:206)
at org.apache.axis2.client.ServiceClient.configureServiceClient(ServiceClient.java:150)
at org.apache.axis2.client.ServiceClient.(ServiceClient.java:143)
at br.inf.portalfiscal.www.nfe.wsdl.nfeconsulta2.NfeConsulta2Stub.(NfeConsulta2Stub.java:91)
at br.inf.portalfiscal.www.nfe.wsdl.nfeconsulta2.NfeConsulta2Stub.(NfeConsulta2Stub.java:77)
at br.inf.portalfiscal.www.nfe.wsdl.nfeconsulta2.NfeConsulta2Stub.(NfeConsulta2Stub.java:126)
at br.com.javac.nfejavac.NFeConsultaNFe.main(NFeConsultaNFe.java:110)

Users with the same issue

2 times, 1 day ago
2 times, 1 day ago
29 times, 2 days ago
Once, 2 days ago
Once, 2 days ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.