java.net.BindException

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Thread-4 Adress already used?
    via GitHub by Shazgul
    ,
  • SQL error
    via GitHub by subarnas
    ,
  • ZeroDivision Error
    via GitHub by subarnas
    ,
  • Jersey Test starts HTTP server twice
    via Stack Overflow by Devour
    ,
  • GitHub comment 39#265737729
    via GitHub by MarvinMenzerath
    ,
  • Sonar started but builds are failing
    via Stack Overflow by PT_C
    ,
    • java.net.BindException: Die Adresse wird bereits verwendet at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:433) at sun.nio.ch.Net.bind(Net.java:425) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at sun.net.httpserver.ServerImpl.<init>(ServerImpl.java:100) at sun.net.httpserver.HttpServerImpl.<init>(HttpServerImpl.java:50) at sun.net.httpserver.DefaultHttpServerProvider.createHttpServer(DefaultHttpServerProvider.java:35) at com.sun.net.httpserver.HttpServer.create(HttpServer.java:130) at ink.abb.pogo.scraper.gui.WebServer$start$1.run(WebServer.kt:27) at java.lang.Thread.run(Thread.java:745)

    Users with the same issue

    pulse00
    1 times, last one,
    paranoid
    2 times, last one,
    Unknown visitor1 times, last one,
    bandoca
    122 times, last one,
    slash
    5 times, last one,
    136 more bugmates