java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Oracle\Berkeley DB XML 2.4.16\bin\libdb_java46.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform". 1) Are there pre-compiled 64-bit libraries available? 2) If not, how to compile the libraries for AMD 64-bit? 3) If not, should we use a 32-bit Java VM? Kind regards Jörn Wagner Edit: I have been able to get rid of the incompatibility error by switching to a 32-bit Java VM (actually jre1.6.0_07). However, now there is a new error: "Uncaught exception from C++ API, errcode = INTERNAL_ERROR

Oracle Community | 582002 | 9 years ago
  1. 0

    Berkeley DB XML running on a Windows XP Professional x64 system

    Oracle Community | 9 years ago | 582002
    java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Oracle\Berkeley DB XML 2.4.16\bin\libdb_java46.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform". 1) Are there pre-compiled 64-bit libraries available? 2) If not, how to compile the libraries for AMD 64-bit? 3) If not, should we use a 32-bit Java VM? Kind regards Jörn Wagner Edit: I have been able to get rid of the incompatibility error by switching to a 32-bit Java VM (actually jre1.6.0_07). However, now there is a new error: "Uncaught exception from C++ API, errcode = INTERNAL_ERROR
  2. 0

    Any Windows 7 64bit version for bdb xml available?

    Oracle Community | 5 years ago | NickAiva
    java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Oracle\Berkeley DB XML 2.5.16\bin\libdb_java48.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
  3. 0

    Berkeley DB XML Can't load 32-bit .dll on a 64-bit platform Netbeans

    Oracle Community | 4 years ago | 991664
    java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Oracle\Berkeley DB XML 2.5.16\bin\libdb_java48.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    tcnative-1.dll Can't load AMD 64-bit .dll on a IA 32-bit platform

    Stack Overflow | 4 years ago | cmdkennedy
    java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\apache-tomcat-7.0.34\bin\tcnative-1.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform". However, I have the 64 bit JRE downloaded, and double-checked my java version: C:\Program Files (x86)\apache-tomcat-7.0.34\bin>java -version java version "1.7.0_10" Java(TM) SE Runtime Environment (build 1.7.0_10-b18) Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode) I've seen this question here before, but in one there was no resolution, and in the other it was an Eclipse issue, but I'm getting this error when I access tomcat directly. How do I find out which "IA 32 bit platform" is being detected, and how do I point Tomcat in the right direction? Also, could this be why my servlet is getting this 404 error through Eclipse? type Status report message /JSPandServlet/Controller description The requested resource is not available. Logs: C:\Program Files (x86)\apache-tomcat-7.0.34\bin>configtest.bat Using CATALINA_BASE: "C:\Program Files (x86)\apache-tomcat-7.0.34" Using CATALINA_HOME: "C:\Program Files (x86)\apache-tomcat-7.0.34" Using CATALINA_TMPDIR: "C:\Program Files (x86)\apache-tomcat-7.0.34\temp" Using JRE_HOME: "C:\Program Files (x86)\Java\jre7" Using CLASSPATH: "C:\Program Files (x86)\apache-tomcat-7.0.34\bin\bootstra p.jar;C:\Program Files (x86)\apache-tomcat-7.0.34\bin\tomcat-juli.jar" java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\apache-tomcat-7.0.34\bin\ tcnative-1.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform at java.lang.ClassLoader$NativeLibrary.load(Native Method)
  6. 0

    All comments on How to Install/set up Arduino+Netbeans for Sammy1Am´s Musical Floppy - YouTube

    youtube.com | 1 year ago
    java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Java\jre7\bin\rxtxSerial.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.UnsatisfiedLinkError

      C:\Program Files (x86)\Oracle\Berkeley DB XML 2.4.16\bin\libdb_java46.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform". 1) Are there pre-compiled 64-bit libraries available? 2) If not, how to compile the libraries for AMD 64-bit? 3) If not, should we use a 32-bit Java VM? Kind regards Jörn Wagner Edit: I have been able to get rid of the incompatibility error by switching to a 32-bit Java VM (actually jre1.6.0_07). However, now there is a new error: "Uncaught exception from C++ API, errcode = INTERNAL_ERROR

      at com.sleepycat.dbxml.dbxml_javaJNI.new_XmlManager()
    2. com.sleepycat.dbxml
      dbxml_javaJNI.new_XmlManager
      1. com.sleepycat.dbxml.dbxml_javaJNI.new_XmlManager(Native Method)
      1 frame