Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Icesoft by menz, 1 year ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
via Icesoft by paulvr, 6 months ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
via hivmr.com by Unknown author, 1 year ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
via Icesoft by upenderc, 1 year ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
via Coderanch by Piotr Sobczyk, 1 year ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
via Coderanch by Diego Creador, 1 year ago
It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl. If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.
com.sun.faces.config.ConfigurationException: It appears the JSP version of the container is older than 2.1 and unable to locate the EL RI expression factory, com.sun.el.ExpressionFactoryImpl.  If not using JSP or the EL RI, make sure the context initialization parameter, com.sun.faces.expressionFactory, is properly set.	at com.sun.faces.config.ConfigureListener.registerELResolverAndListenerWithJsp(ConfigureListener.java:546)	at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:212)	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)	at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:927)	at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:890)	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:492)	at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1218)	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:293)	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)	at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1306)	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1570)	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1579)	at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1559)	at java.lang.Thread.run(Thread.java:619)