java.net.BindException

Address already in use[[

Samebug tips3

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web824

  • via Unknown by 1009107,
  • via Unknown by 724446,
  • via Unknown by user11001592,
  • Stack trace

    • java.net.BindException: Address already in use[[ at sun.nio.ch.Net.bind(Native Method) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52) at com.siebel.analytics.javahost.Acceptor.bind(Acceptor.java:92) at com.siebel.analytics.javahost.ApplicationImpl.init(ApplicationImpl.java:232) at com.siebel.analytics.javahost.standalone.Main.init(Main.java:146) at com.siebel.analytics.javahost.standalone.Main.main(Main.java:28)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    AxeloAxelo
    8 times, last one
    slashslash
    8 times, last one
    zsambokizsamboki
    6 times, last one
    Unknown UserUnknown User
    Once,
    rocdayrocday
    2 times, last one
    134 more bugmates