java.lang.LinkageError

loader (instance of org/mule/runtime/module/launcher/MuleSharedDomainClassLoader): attempted duplicate class definition for name: "org/mule/runtime/module/artifact/classloader/DefaultResourceReleaser"

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web408

  • via Unknown by Mariano De Sousa Bispo,
  • via Stack Overflow by javagc
    ,
  • Stack trace

    • java.lang.LinkageError: loader (instance of org/mule/runtime/module/launcher/MuleSharedDomainClassLoader): attempted duplicate class definition for name: "org/mule/runtime/module/artifact/classloader/DefaultResourceReleaser" at java.lang.ClassLoader.defineClass1(Native Method)[?:1.8.0_92] at java.lang.ClassLoader.defineClass(ClassLoader.java:763)[?:1.8.0_92] at java.lang.ClassLoader.defineClass(ClassLoader.java:642)[?:1.8.0_92] at org.mule.runtime.module.artifact.classloader.MuleArtifactClassLoader.createResourceReleaserInstance(MuleArtifactClassLoader.java:110)[mule-module-artifact-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.artifact.classloader.MuleArtifactClassLoader.dispose(MuleArtifactClassLoader.java:89)[mule-module-artifact-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.launcher.domain.DefaultMuleDomain.dispose(DefaultMuleDomain.java:241)[mule-module-launcher-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.launcher.domain.DomainWrapper.dispose(DomainWrapper.java:48)[mule-module-launcher-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.launcher.DeploymentDirectoryWatcher.stopArtifacts(DeploymentDirectoryWatcher.java:231)[mule-module-launcher-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.launcher.DeploymentDirectoryWatcher.stop(DeploymentDirectoryWatcher.java:214)[mule-module-launcher-4.0.0-M2.jar:4.0.0-M2] at org.mule.runtime.module.launcher.MuleDeploymentService.stop(MuleDeploymentService.java:138)[mule-module-launcher-4.0.0-M2.jar:4.0.0-M2] at org.mule.test.infrastructure.deployment.FakeMuleServer.stop(FakeMuleServer.java:129)[mule-tests-infrastructure-4.0.0-M2.jar:4.0.0-M2]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown visitor
    Unknown visitorOnce,
    derproggerderprogger
    4 times, last one
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    40 more bugmates