org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [2].

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Java 8 final shipped on 18 March 2014. Stash currently fails to start when using it. {noformat:title=server.xml} 2014-03-30 22:23:51,148 ERROR [FelixDispatchQueue] c.a.p.o.c.f.FelixOsgiContainerManager Framework error in bundle org.springframework.osgi.extender org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [2]. at org.apache.felix.framework.Felix.activateBundle(Felix.java:1889) ~[org.apache.felix.framework-3.0.9.jar:na] at java.lang.Thread.run(Thread.java:744) [na:1.8.0] ... 3 frames trimmed Caused by: java.lang.IllegalStateException: Cannot create ConcurrentHashMap - neither JDK 1.5 nor backport-concurrent available on the classpath at org.springframework.core.CollectionFactory.createConcurrentMap(CollectionFactory.java:229) ~[spring-core-4.0.2.RELEASE.jar:4.0.2.RELEASE] at java.lang.Class.newInstance(Class.java:433) ~[na:1.8.0] ... 2 common frames omitted {noformat} {noformat:title=On the UI} A fatal error has occurred The following problems occurred which prevents Atlassian Stash from starting correctly: Required plugin com.atlassian.templaterenderer.api has failed to start Required plugin com.atlassian.stash.stash-jira-integration has failed to start Required plugin com.atlassian.atlassian-failure-cache-plugin has failed to start Required plugin com.atlassian.crowd.embedded.admin has failed to start Required plugin com.atlassian.plugins.atlassian-nav-links-plugin has failed to start Required plugin com.atlassian.templaterenderer.atlassian-template-renderer-velocity1.6-plugin has failed to start Required plugin com.atlassian.oauth.consumer.sal has failed to start Required plugin com.atlassian.stash.stash-rest-common has failed to start Required plugin com.atlassian.stash.stash-rest has failed to start Required plugin com.atlassian.applinks.applinks-plugin has failed to start Required plugin com.atlassian.auiplugin has failed to start Required plugin com.atlassian.oauth.consumer has failed to start Required plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin has failed to start Required plugin com.atlassian.soy.soy-template-plugin has failed to start Required plugin com.atlassian.activeobjects.activeobjects-plugin has failed to start Required plugin com.atlassian.stash.stash-sal has failed to start Required plugin com.atlassian.stash.stash-embcwd-admin-spi-impl has failed to start Required plugin com.atlassian.plugins.atlassian-plugins-webresource-plugin has failed to start Required plugin com.atlassian.stash.stash-stp-integration has failed to start Required plugin com.atlassian.oauth.serviceprovider.sal has failed to start Required plugin com.atlassian.stash.stash-scm-request-checks has failed to start Required plugin com.atlassian.scala.plugins.scala-2.9-provider-plugin has failed to start Required plugin com.atlassian.plugins.jquery has failed to start Required plugin com.atlassian.plugins.less-transformer-plugin has failed to start Required plugin com.atlassian.oauth.serviceprovider has failed to start Required plugin com.atlassian.stash.stash-scm-git has failed to start Required plugin com.atlassian.stash.stash-nav-links has failed to start Required plugin com.atlassian.stash.stash-velocity-helper has failed to start Required plugin com.atlassian.oauth.admin has failed to start Required plugin com.atlassian.plugins.rest.atlassian-rest-module has failed to start {noformat}
    via by Jason Hinch,
  • Java 8 final shipped on 18 March 2014. Stash currently fails to start when using it. {noformat:title=server.xml} 2014-03-30 22:23:51,148 ERROR [FelixDispatchQueue] c.a.p.o.c.f.FelixOsgiContainerManager Framework error in bundle org.springframework.osgi.extender org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [2]. at org.apache.felix.framework.Felix.activateBundle(Felix.java:1889) ~[org.apache.felix.framework-3.0.9.jar:na] at java.lang.Thread.run(Thread.java:744) [na:1.8.0] ... 3 frames trimmed Caused by: java.lang.IllegalStateException: Cannot create ConcurrentHashMap - neither JDK 1.5 nor backport-concurrent available on the classpath at org.springframework.core.CollectionFactory.createConcurrentMap(CollectionFactory.java:229) ~[spring-core-4.0.2.RELEASE.jar:4.0.2.RELEASE] at java.lang.Class.newInstance(Class.java:433) ~[na:1.8.0] ... 2 common frames omitted {noformat} {noformat:title=On the UI} A fatal error has occurred The following problems occurred which prevents Atlassian Stash from starting correctly: Required plugin com.atlassian.templaterenderer.api has failed to start Required plugin com.atlassian.stash.stash-jira-integration has failed to start Required plugin com.atlassian.atlassian-failure-cache-plugin has failed to start Required plugin com.atlassian.crowd.embedded.admin has failed to start Required plugin com.atlassian.plugins.atlassian-nav-links-plugin has failed to start Required plugin com.atlassian.templaterenderer.atlassian-template-renderer-velocity1.6-plugin has failed to start Required plugin com.atlassian.oauth.consumer.sal has failed to start Required plugin com.atlassian.stash.stash-rest-common has failed to start Required plugin com.atlassian.stash.stash-rest has failed to start Required plugin com.atlassian.applinks.applinks-plugin has failed to start Required plugin com.atlassian.auiplugin has failed to start Required plugin com.atlassian.oauth.consumer has failed to start Required plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin has failed to start Required plugin com.atlassian.soy.soy-template-plugin has failed to start Required plugin com.atlassian.activeobjects.activeobjects-plugin has failed to start Required plugin com.atlassian.stash.stash-sal has failed to start Required plugin com.atlassian.stash.stash-embcwd-admin-spi-impl has failed to start Required plugin com.atlassian.plugins.atlassian-plugins-webresource-plugin has failed to start Required plugin com.atlassian.stash.stash-stp-integration has failed to start Required plugin com.atlassian.oauth.serviceprovider.sal has failed to start Required plugin com.atlassian.stash.stash-scm-request-checks has failed to start Required plugin com.atlassian.scala.plugins.scala-2.9-provider-plugin has failed to start Required plugin com.atlassian.plugins.jquery has failed to start Required plugin com.atlassian.plugins.less-transformer-plugin has failed to start Required plugin com.atlassian.oauth.serviceprovider has failed to start Required plugin com.atlassian.stash.stash-scm-git has failed to start Required plugin com.atlassian.stash.stash-nav-links has failed to start Required plugin com.atlassian.stash.stash-velocity-helper has failed to start Required plugin com.atlassian.oauth.admin has failed to start Required plugin com.atlassian.plugins.rest.atlassian-rest-module has failed to start {noformat}
    via by Jason Hinch [Atlassian],
  • Newbee question
    via Stack Overflow by jef
    ,
  • Datanucleus 4.0.3 with OSGI and JDO
    via Stack Overflow by Cristian Rinaldi
    ,
    • org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [2]. at org.apache.felix.framework.Felix.activateBundle(Felix.java:1889)[org.apache.felix.framework-3.0.9.jar:na] at java.lang.Thread.run(Thread.java:744)[na:1.8.0]
    No Bugmate found.