java.lang.UnsatisfiedLinkError: javaagent_api_init

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Oracle Community by 3004, 1 year ago
via Google Groups by Gurunathan, 5 months ago
java.lang.UnsatisfiedLinkError: javaagent_api_init
at netegrity.siteminder.javaagent.AgentAPI.javaagent_api_init(Native Method)
at netegrity.siteminder.javaagent.AgentAPI.init(AgentAPI.java:488)
at com.netegrity.ra.policyserver.impl.PSManagedConnectionFactory.createManagedConnection(PSManagedConnectionFactory.java:200)
at weblogic.connector.common.internal.ConnectionFactory.createResource(ConnectionFactory.java:127)
at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1145)
at weblogic.common.resourcepool.ResourcePoolImpl.makeResources(ResourcePoolImpl.java:1079)
at weblogic.common.resourcepool.ResourcePoolImpl.setInitialCapacity(ResourcePoolImpl.java:739)
at weblogic.connector.common.internal.ConnectionPoolManager.updateInitialCapacity(ConnectionPoolManager.java:495)
at weblogic.connector.common.internal.ConnectionPoolManager.preparePool(ConnectionPoolManager.java:140)
at weblogic.connector.deploy.Deployer.preparePool(Deployer.java:618)
at weblogic.connector.deploy.Deployer.prepare(Deployer.java:230)
at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.java:248)
at weblogic.j2ee.J2EEApplicationContainer.prepareModule(J2EEApplicationContainer.java:3142)
at weblogic.j2ee.J2EEApplicationContainer.prepareModules(J2EEApplicationContainer.java:1583)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1227)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2EEApplicationContainer.java:1070)
at weblogic.management.deploy.slave.SlaveDeployer$ComponentActivateTask.prepareContainer(SlaveDeployer.java:2513)
at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.createContainer(SlaveDeployer.java:2463)
at weblogic.management.deploy.slave.SlaveDeployer$ActivateTask.prepare(SlaveDeployer.java:2379)
at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:866)
at weblogic.management.deploy.slave.SlaveDeployer.prepareDelta(SlaveDeployer.java:594)
at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:508)
at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:25)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Know the solutions? Share your knowledge to help other developers to debug faster.