org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • GitHub comment 33#156305469
    via GitHub by ben-manes
    ,
  • Re: Deploy Sling to JBoss EAP 6.4.0
    via by Guillaume Lucazeau,
  • - Attempting to upgrade Nexus 3 MS 6 to Nexus 3 MS 7 results in an error. - Attempting to install Nexus 3 MS 7 and use the data directory from MS 6 results in an error The error is {code:bash} 2016-03-21 23:19:04,210-0400 DEBUG [FelixStartLevel] *SYSTEM org.apache.commons.io - BundleEvent STARTED - org.apache.commons.io ERROR: Bundle org.sonatype.nexus.commands [168] Error starting mvn:org.sonatype.nexus/nexus-commands/3.0.0-b2015110601 (org.osgi.framework.BundleException: Unable to resolve org.sonatype.nexus.commands [168](R 168.0): missing requirement [org.sonatype.nexus.commands [168](R 168.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.service.command)(version>=0.16.0)) [caused by: Unable to resolve org.apache.karaf.shell.console [31](R 31.0): missing requirement [org.apache.karaf.shell.console [31](R 31.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.boot.principal)(version>=3.0.0)(!(version>=4.0.0)))] Unresolved requirements: [[org.sonatype.nexus.commands [168](R 168.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.service.command)(version>=0.16.0))]) org.osgi.framework.BundleException: Unable to resolve org.sonatype.nexus.commands [168](R 168.0): missing requirement [org.sonatype.nexus.commands [168](R 168.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.service.command)(version>=0.16.0)) [caused by: Unable to resolve org.apache.karaf.shell.console [31](R 31.0): missing requirement [org.apache.karaf.shell.console [31](R 31.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.jaas.boot.principal)(version>=3.0.0)(!(version>=4.0.0)))] Unresolved requirements: [[org.sonatype.nexus.commands [168](R 168.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.service.command)(version>=0.16.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) at java.lang.Thread.run(Thread.java:745) {code}
    via by Mohammad Minaie,
  • GitHub comment 62#287401562
    via GitHub by shumy
    ,
    • org.osgi.framework.BundleException: Unable to resolve com.rabbitmq.client [5](R 5.0): missing requirement [com.rabbitmq.client [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package =junit.framework) Unresolved requirements: [[com.rabbitmq.client [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=junit.framework)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111) at org.apache.felix.framework.Felix.startBundle(Felix.java:2117) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) at java.lang.Thread.run(Thread.java:745)

    Users with the same issue

    davidvanlaatum
    2631 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    13 more bugmates