java.lang.UnsatisfiedLinkError: Can't load library: C:/Oracle/Middleware/Oracle_IDM1/oui/lib/win32/oraInstaller.dll

Oracle Community | 918074 | 5 years ago
  1. 0

    Unable to run upgrade assistant utility in OIM 11.1.1.5

    Oracle Community | 5 years ago | 918074
    java.lang.UnsatisfiedLinkError: Can't load library: C:/Oracle/Middleware/Oracle_IDM1/oui/lib/win32/oraInstaller.dll
  2. 0

    ODI11g Upgrade from 11.1.1.3 to 11.1.1.5 UPGAST-00055: error

    Oracle Community | 5 years ago | user12220555
    java.lang.UnsatisfiedLinkError: Can't load library: /u01/oracle/middleware/Oracle_ODI1/oui/lib/linux64/liboraInstaller.so
  3. 0

    EMCA create repository fails - 100% CPU utilization

    Oracle Community | 5 years ago | 878706
    java.lang.UnsatisfiedLinkError: /opt/oracle/product/11.2.0/dbhome_1/oui/lib/linux/liboraInstaller.so: /opt/oracle/product/11.2.0/dbhome_1/oui/lib/linux/liboraInstaller.so: wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    SP2-0750: You may need to set ORACLE_HOME

    Server Fault | 3 years ago | bjan
    java.lang.UnsatisfiedLinkError: Can't load library: C:/Oracle/product/11.1.0/db_ 1;/oui/lib/win32/oraInstaller.dll
  6. 0

    DBCA fails with java.lang.UnsatisfiedLinkError: Can't load library: /u01/oracle/prod/tech_st/product/11.2.0/db_1/oui/lib/linux/liboraInstaller.so Error in Oracle 11g

    Oracle Community | 3 years ago | K.Vijay
    java.lang.UnsatisfiedLinkError: Can't load library: /u01/oracle/prod/tech_st/product/11.2.0/db_1/oui/lib/linux/liboraInstaller.so

  1. franky li 8 times, last 1 month ago
  2. Lukasmcd14 1 times, last 4 months ago
  3. Christopher 4 times, last 7 months ago
  4. xgao 1 times, last 11 months ago
42 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsatisfiedLinkError

    Can't load library: C:/Oracle/Middleware/Oracle_IDM1/oui/lib/win32/oraInstaller.dll

    at java.lang.ClassLoader.loadLibrary()
  2. Java RT
    System.load
    1. java.lang.ClassLoader.loadLibrary(ClassLoader.java:1705)
    2. java.lang.Runtime.load0(Runtime.java:770)
    3. java.lang.System.load(System.java:1004)
    3 frames
  3. oracle.sysman.oii
    OiicStandardInventorySession.initSession
    1. oracle.sysman.oii.oiip.osd.win32.OiipwWin32NativeCalls.loadNativeLib(OiipwWin32NativeCalls.java:1509)
    2. oracle.sysman.oii.oiip.osd.win32.OiipwWin32NativeCalls.<clinit>(OiipwWin32NativeCalls.java:50)
    3. oracle.sysman.oii.oiip.oiipg.OiipgEnvironment.getEnv(OiipgEnvironment.java:211)
    4. oracle.sysman.oii.oiip.oiipg.OiipgPropertyLoader.initUnixPtrFileLoc(OiipgPropertyLoader.java:213)
    5. oracle.sysman.oii.oiip.oiipg.OiipgPropertyLoader.<clinit>(OiipgPropertyLoader.java:126)
    6. oracle.sysman.oii.oiic.OiicStandardInventorySession.updateProperties(OiicStandardInventorySession.java:461)
    7. oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:257)
    8. oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:232)
    9. oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:181)
    9 frames
  4. oracle.ias.upgrade
    UpgradeDriver.main
    1. oracle.ias.upgrade.OUIInventory.initAll(OUIInventory.java:86)
    2. oracle.ias.upgrade.gui.UAWizard.init(UAWizard.java:446)
    3. oracle.ias.upgrade.UpgradeDriver.gui(UpgradeDriver.java:276)
    4. oracle.ias.upgrade.UpgradeDriver.main(UpgradeDriver.java:179)
    4 frames