java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • project.getRootModule()=hudson.maven.MavenModule@37bbea67[VNUE/nl.esperantoxl.vnue:vnue-parent][VNUE/nl.esperantoxl.vnue:vnue-parent][relativePath:] FATAL: null java.lang.NullPointerException at hudson.maven.MavenModule.getSubsidiaries(MavenModule.java:186) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:210) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:201) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:181) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:312) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:341) at hudson.tasks.MailSender.createUnstableMail(MailSender.java:181) at hudson.tasks.MailSender.getMail(MailSender.java:152) at hudson.tasks.MailSender.execute(MailSender.java:95) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:53) at hudson.maven.Maven3Builder.end(Maven3Builder.java:179) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:762) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:460) at hudson.model.Run.run(Run.java:1404) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:470) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230) The test email is correctly sent (jenkins main config screen). The 'send email to the person who broke the build' checkbox has been set. The SCM change output for the build shows odd information: This page captures the polling log that triggered this build. Started on 19-okt-2011 15:54:27 Received SCM poll call on for VNUE on 19-okt-2011 15:54:28 https://extranet.esperantoxl.nl/subversion/vnue/basisregistratie/trunk heeft revisie 14.720 (veranderd van 14.718) Done. Took 0,42 seconden Changes found The SVN checkin was performed by a authenticated user. Jenkins version 1.435 Jenkins Subversion Plug-in: 1.33 This is a migration test (we are looking to update our 'real' jenkins). The buildserver does not have this problem (Jenkins 1.405) Environment: apache-tomcat-7.0.12 Java 1.6.0_25-b06 (SUN)
    via by Dimar van Rietschoten,
  • project.getRootModule()=hudson.maven.MavenModule@37bbea67[VNUE/nl.esperantoxl.vnue:vnue-parent][VNUE/nl.esperantoxl.vnue:vnue-parent][relativePath:] FATAL: null java.lang.NullPointerException at hudson.maven.MavenModule.getSubsidiaries(MavenModule.java:186) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:210) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:201) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:181) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:312) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:341) at hudson.tasks.MailSender.createUnstableMail(MailSender.java:181) at hudson.tasks.MailSender.getMail(MailSender.java:152) at hudson.tasks.MailSender.execute(MailSender.java:95) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:53) at hudson.maven.Maven3Builder.end(Maven3Builder.java:179) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:762) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:460) at hudson.model.Run.run(Run.java:1404) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:470) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230) The test email is correctly sent (jenkins main config screen). The 'send email to the person who broke the build' checkbox has been set. The SCM change output for the build shows odd information: This page captures the polling log that triggered this build. Started on 19-okt-2011 15:54:27 Received SCM poll call on for VNUE on 19-okt-2011 15:54:28 https://extranet.esperantoxl.nl/subversion/vnue/basisregistratie/trunk heeft revisie 14.720 (veranderd van 14.718) Done. Took 0,42 seconden Changes found The SVN checkin was performed by a authenticated user. Jenkins version 1.435 Jenkins Subversion Plug-in: 1.33 This is a migration test (we are looking to update our 'real' jenkins). The buildserver does not have this problem (Jenkins 1.405) Environment: apache-tomcat-7.0.12 Java 1.6.0_25-b06 (SUN)
    via by Dimar van Rietschoten,
  • PTC Integrity Plugin - Jenkins - Jenkins Wiki
    via by Unknown author,
  • Here is an error that I have randomly, after a maven build. The maven build seems to have been successful, but it seems that a post process creates a problem. [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 32 seconds [INFO] Finished at: Wed Oct 21 18:32:31 EDT 2009 [INFO] Final Memory: 38M/63M [INFO] ------------------------------------------------------------------------ ERROR: Processing failed due to a bug in the code. Please report this to users@hudson.dev.java.net java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:200) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:170) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:164) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:52) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:159) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:270) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:320) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:156) at hudson.tasks.MailSender.getMail(MailSender.java:147) at hudson.tasks.MailSender.execute(MailSender.java:81) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:54) at hudson.maven.MavenModuleSetBuild$Builder.end(MavenModuleSetBuild.java:679) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:482) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:375) at hudson.model.Run.run(Run.java:1120) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:303) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:123) project=hudson.maven.MavenModuleSet@9a99eb[swix] project.getModules()=[hudson.maven.MavenModule@1b2b450[swix/com.zerobase.swix:sw ix-aggregator], hudson.maven.MavenModule@15c13ef[swix/com.zerobase.swix:swix- client], hudson.maven.MavenModule@1dd9169[swix/com.zerobase.swix:swix-parent], hudson.maven.MavenModule@20dcb7[swix/com.zerobase.swix:swix-scenarioconfig], hudson.maven.MavenModule@17aa2a8[swix/com.zerobase.swix:swix-ujac_ui]] project.getRootModule()=hudson.maven.MavenModule@1b2b450[swix/com.zerobase.swix: swix-aggregator] FATAL: null java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:200) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:170) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:164) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:52) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:159) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:270) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:320) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:156) at hudson.tasks.MailSender.getMail(MailSender.java:147) at hudson.tasks.MailSender.execute(MailSender.java:81) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:54) at hudson.maven.MavenModuleSetBuild$Builder.end(MavenModuleSetBuild.java:679) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:482) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:375) at hudson.model.Run.run(Run.java:1120) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:303) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:123)
    via by creto,
  • Here is an error that I have randomly, after a maven build. The maven build seems to have been successful, but it seems that a post process creates a problem. [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESSFUL [INFO] ------------------------------------------------------------------------ [INFO] Total time: 32 seconds [INFO] Finished at: Wed Oct 21 18:32:31 EDT 2009 [INFO] Final Memory: 38M/63M [INFO] ------------------------------------------------------------------------ ERROR: Processing failed due to a bug in the code. Please report this to users@hudson.dev.java.net java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:200) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:170) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:164) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:52) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:159) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:270) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:320) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:156) at hudson.tasks.MailSender.getMail(MailSender.java:147) at hudson.tasks.MailSender.execute(MailSender.java:81) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:54) at hudson.maven.MavenModuleSetBuild$Builder.end(MavenModuleSetBuild.java:679) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:482) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:375) at hudson.model.Run.run(Run.java:1120) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:303) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:123) project=hudson.maven.MavenModuleSet@9a99eb[swix] project.getModules()=[hudson.maven.MavenModule@1b2b450[swix/com.zerobase.swix:sw ix-aggregator], hudson.maven.MavenModule@15c13ef[swix/com.zerobase.swix:swix- client], hudson.maven.MavenModule@1dd9169[swix/com.zerobase.swix:swix-parent], hudson.maven.MavenModule@20dcb7[swix/com.zerobase.swix:swix-scenarioconfig], hudson.maven.MavenModule@17aa2a8[swix/com.zerobase.swix:swix-ujac_ui]] project.getRootModule()=hudson.maven.MavenModule@1b2b450[swix/com.zerobase.swix: swix-aggregator] FATAL: null java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:200) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:170) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:164) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:52) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:159) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:270) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:320) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:156) at hudson.tasks.MailSender.getMail(MailSender.java:147) at hudson.tasks.MailSender.execute(MailSender.java:81) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:54) at hudson.maven.MavenModuleSetBuild$Builder.end(MavenModuleSetBuild.java:679) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:482) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:375) at hudson.model.Run.run(Run.java:1120) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:303) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:123)
    via by creto,
  • PTC Integrity Plugin - Jenkins - Jenkins Wiki
    via by Unknown author,
  • I have configured a post build action to deploy the bundles in Archiva repository. But I sometimes get the below error intermittently while executing the post build action step. This does not happen always but at sometimes. ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:246) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:215) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:208) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:183) at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:216) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:181) at hudson.tasks.MailSender.getMail(MailSender.java:168) at hudson.tasks.MailSender.execute(MailSender.java:100) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:55) at hudson.maven.AbstractMavenBuilder.end(AbstractMavenBuilder.java:103) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:758) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:593) at hudson.model.Run.execute(Run.java:1567) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:237) project=hudson.maven.MavenModuleSet@77dbb506[DGW_Release_6_Build] project.getModules()=[hudson.maven.MavenModule@58759e1d[DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][relativePath:DGWManualRepairSchema], hudson.maven.MavenModule@38e0028d[DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][relativePath:DGWProcessor], hudson.maven.MavenModule@7e6a41ea[DGW_Release_6_Build/com.centurylink.dgw:dgwschema][DGW_Release_6_Build/com.centurylink.dgw:dgwschema][relativePath:DGWSchema], hudson.maven.MavenModule@2b029273[DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][relativePath:DGWStatusReporterSchema], hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow]] project.getRootModule()=hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow] FATAL: null
    via by Premkumar Dhanarajan,
  • I have configured a post build action to deploy the bundles in Archiva repository. But I sometimes get the below error intermittently while executing the post build action step. This does not happen always but at sometimes. ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com java.lang.NullPointerException at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:246) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:215) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:208) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:183) at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:216) at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:181) at hudson.tasks.MailSender.getMail(MailSender.java:168) at hudson.tasks.MailSender.execute(MailSender.java:100) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:55) at hudson.maven.AbstractMavenBuilder.end(AbstractMavenBuilder.java:103) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:758) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:593) at hudson.model.Run.execute(Run.java:1567) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:237) project=hudson.maven.MavenModuleSet@77dbb506[DGW_Release_6_Build] project.getModules()=[hudson.maven.MavenModule@58759e1d[DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][relativePath:DGWManualRepairSchema], hudson.maven.MavenModule@38e0028d[DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][relativePath:DGWProcessor], hudson.maven.MavenModule@7e6a41ea[DGW_Release_6_Build/com.centurylink.dgw:dgwschema][DGW_Release_6_Build/com.centurylink.dgw:dgwschema][relativePath:DGWSchema], hudson.maven.MavenModule@2b029273[DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][relativePath:DGWStatusReporterSchema], hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow]] project.getRootModule()=hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow] FATAL: null
    via by Premkumar Dhanarajan,
    • java.lang.NullPointerException at hudson.maven.MavenModule.getSubsidiaries(MavenModule.java:186) at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:210) at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:201) at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51) at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:181) at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:312) at hudson.tasks.MailSender.createEmptyMail(MailSender.java:341) at hudson.tasks.MailSender.createUnstableMail(MailSender.java:181) at hudson.tasks.MailSender.getMail(MailSender.java:152) at hudson.tasks.MailSender.execute(MailSender.java:95) at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:53) at hudson.maven.Maven3Builder.end(Maven3Builder.java:179) at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:762) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:460) at hudson.model.Run.run(Run.java:1404) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:470) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230)
    No Bugmate found.