java.net.UnknownHostException

tip

Check if you don't have a VPN or something like this messing with your connection. Also, check Jenkins DNS configurations (try to start it with "--dns 8.8.8.8".

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • No hipchat notifications received. Also see this in the logs: Error posting to HipChat java.net.UnknownHostException: null at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:178) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) at java.net.Socket.connect(Socket.java:579) at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618) at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:407) at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:135) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:117) at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707) at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387) at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323) at jenkins.plugins.hipchat.StandardHipChatService.publish(StandardHipChatService.java:48) at jenkins.plugins.hipchat.ActiveNotifier.notifyStart(ActiveNotifier.java:53) at jenkins.plugins.hipchat.ActiveNotifier.started(ActiveNotifier.java:46) at jenkins.plugins.hipchat.HipChatNotifier$HipChatJobProperty.prebuild(HipChatNotifier.java:203) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:806) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:801) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:797) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532) at hudson.model.Run.execute(Run.java:1740) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:233) I tried going into global config and hitting save. Makes no difference, rolling back to 1.6 for now.
    via by Gennady Feldman,
  • No hipchat notifications received. Also see this in the logs: Error posting to HipChat java.net.UnknownHostException: null at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:178) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) at java.net.Socket.connect(Socket.java:579) at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618) at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:407) at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:135) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:117) at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707) at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387) at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323) at jenkins.plugins.hipchat.StandardHipChatService.publish(StandardHipChatService.java:48) at jenkins.plugins.hipchat.ActiveNotifier.notifyStart(ActiveNotifier.java:53) at jenkins.plugins.hipchat.ActiveNotifier.started(ActiveNotifier.java:46) at jenkins.plugins.hipchat.HipChatNotifier$HipChatJobProperty.prebuild(HipChatNotifier.java:203) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:806) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:801) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:797) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532) at hudson.model.Run.execute(Run.java:1740) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:233) I tried going into global config and hitting save. Makes no difference, rolling back to 1.6 for now.
    via by Gennady Feldman,
  • GitHub comment 132#183013253
    via GitHub by bradical
    ,
  • App Factory 2.1.0 error when starting
    via Stack Overflow by Omar Flores
    ,
  • URL for Symantec VIP Web Service
    via by Unknown author,
  • Java couchdb4j DB connection
    via Stack Overflow by user1959214
    ,
    • java.net.UnknownHostException: null at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:178) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) at java.net.Socket.connect(Socket.java:579) at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618) at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:407) at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:135) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:117) at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707) at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387) at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323) at jenkins.plugins.hipchat.StandardHipChatService.publish(StandardHipChatService.java:48) at jenkins.plugins.hipchat.ActiveNotifier.notifyStart(ActiveNotifier.java:53) at jenkins.plugins.hipchat.ActiveNotifier.started(ActiveNotifier.java:46) at jenkins.plugins.hipchat.HipChatNotifier$HipChatJobProperty.prebuild(HipChatNotifier.java:203) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:806) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:801) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:797) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532) at hudson.model.Run.execute(Run.java:1740) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:233)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    111 more bugmates