java.lang.RuntimeException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • On a few of our Jenkins builds, we get a deployment failure. There is no obvious reason as to why. I have compared the Jenkins config.xml from a job that does a successful deployment to a job that fails deployment, have made the settings the same, but with no successful deployment. We can copy and run the java command (/opt/buildjdks/jdk1.8.0_25/bin/java -Xms256M -Xmx1024M -cp /opt/weblogic-deployer/wlfullclient.jar weblogic.Deployer -debug -stage -remote -verbose -upload -name appname -source /opt/jenkins/jobs/appname-build-deploy-dev/modules/com.apps.appname$appname/builds/22/archive/com.apps.appname/appname/1.0.0-SNAPSHOT/appname-1.0.0-SNAPSHOT.war -targets devCluster -adminurl t3://server:7003 -userconfigfile /opt/weblogic-deployer/wls_userConfig.properties -userkeyfile /opt/weblogic-deployer/wls_userConfig.key -deploy) Jenkins is running manually on the Jenkins server console and the deployment works successfully every time, but running the build task we get the error below, every time. java.lang.RuntimeException: task completed abnormally (exit code = 1) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.deploy(DeploymentTaskServiceImpl.java:252) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:181) at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:232) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1046) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670) at hudson.model.Run.execute(Run.java:1776) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531) at hudson.model.ResourceController.execute(ResourceController.java:89) at hudson.model.Executor.run(Executor.java:240) ERROR: [WeblogicDeploymentPlugin] - Failed to deploy. [INFO] ------------------------------------------------------------------------ [INFO] DEPLOYMENT FAILURE [INFO] ------------------------------------------------------------------------ Have scoured the internet, have found a few others having the same issue but no resolution posted. One person suggests adding into the java classpath additional jars weblogic, cryptoj.jar, along with wlfullclient.jar. I have tried this with no changes to the build deployment error above.
    via by trevorw,
  • On a few of our Jenkins builds, we get a deployment failure. There is no obvious reason as to why. I have compared the Jenkins config.xml from a job that does a successful deployment to a job that fails deployment, have made the settings the same, but with no successful deployment. We can copy and run the java command (/opt/buildjdks/jdk1.8.0_25/bin/java -Xms256M -Xmx1024M -cp /opt/weblogic-deployer/wlfullclient.jar weblogic.Deployer -debug -stage -remote -verbose -upload -name appname -source /opt/jenkins/jobs/appname-build-deploy-dev/modules/com.apps.appname$appname/builds/22/archive/com.apps.appname/appname/1.0.0-SNAPSHOT/appname-1.0.0-SNAPSHOT.war -targets devCluster -adminurl t3://server:7003 -userconfigfile /opt/weblogic-deployer/wls_userConfig.properties -userkeyfile /opt/weblogic-deployer/wls_userConfig.key -deploy) Jenkins is running manually on the Jenkins server console and the deployment works successfully every time, but running the build task we get the error below, every time. java.lang.RuntimeException: task completed abnormally (exit code = 1) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.deploy(DeploymentTaskServiceImpl.java:252) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:181) at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:232) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1046) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670) at hudson.model.Run.execute(Run.java:1776) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531) at hudson.model.ResourceController.execute(ResourceController.java:89) at hudson.model.Executor.run(Executor.java:240) ERROR: [WeblogicDeploymentPlugin] - Failed to deploy. [INFO] ------------------------------------------------------------------------ [INFO] DEPLOYMENT FAILURE [INFO] ------------------------------------------------------------------------ Have scoured the internet, have found a few others having the same issue but no resolution posted. One person suggests adding into the java classpath additional jars weblogic, cryptoj.jar, along with wlfullclient.jar. I have tried this with no changes to the build deployment error above.
    via by trevorw,
  • Jenkins deployment into Weblogic 12c FAILING
    via by Sudeesh Naidu,
    • java.lang.RuntimeException: task completed abnormally (exit code = 1) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.deploy(DeploymentTaskServiceImpl.java:252) at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:181) at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:232) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1046) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670) at hudson.model.Run.execute(Run.java:1776) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531) at hudson.model.ResourceController.execute(ResourceController.java:89) at hudson.model.Executor.run(Executor.java:240)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,