java.lang.NoClassDefFoundError: sun.awt.X11.XToolkit (initialization failure)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via Oracle Community by user3129287, 1 year ago
sun.awt.X11.XToolkit (initialization failure)
via Google Groups by Sam, 10 months ago
tmp.constants.util.Presentation (initialization failure)
via Stack Overflow by buddha089
, 2 years ago
javax.xml.ws.spi.Provider (initialization failure)
via Stack Overflow by newbie
, 2 years ago
com.test.Delegate (initialization failure)
via Stack Overflow by user1093643
, 2 years ago
com.ibm.xtq.bcel.util.SyntheticRepository (initialization failure)
via ibm.com by Unknown author, 9 months ago
java.lang.NoClassDefFoundError: sun.awt.X11.XToolkit (initialization failure)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:134)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.