java.lang.UnsupportedClassVersionError: com/nirima/docker/client/DockerException : Unsupported major.minor version 51.0

Jenkins JIRA | Michael Prokop | 3 years ago
  1. 0
    You're using an older version of java with classes compiled for java7
    via GitHub by Athou
  2. Speed up your debug routine!

    Automated exception search integrated into your IDE

  3. 0

    Does the laster version of docker plugin requires java 1.7 ?

    Google Groups | 2 years ago | ycollet
    java.io.IOException: Unable to load com.nirima.jenkins.plugins.docker.PluginImpl from docker-plugin
  4. 0
    This might be caused by and outdated version of Java, SonarQube now uses Java 8 as default. You might upgrade java or use an older version of SonarQube.

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.UnsupportedClassVersionError

      com/nirima/docker/client/DockerException : Unsupported major.minor version 51.0

      at com.nirima.jenkins.plugins.docker.builder.DockerBuilderControl$DescriptorImpl.<init>()
    2. com.nirima.jenkins
      DockerBuilderControl$DescriptorImpl.<init>
      1. com.nirima.jenkins.plugins.docker.builder.DockerBuilderControl$DescriptorImpl.<init>(Unknown Source)
      1 frame