java.lang.IllegalArgumentException: Source may not be null

Atlassian JIRA | Ian Pojman | 1 decade ago
  1. 0

    Did a clean install of jira1.3beta2, went through the setup fine. When I log in, I get the following error, and (sometimes) below that is the regular jira dashboard form with just the left hand side of the dashboard only (the Assigned to Me, Reported by Me areas are not there): 500 Internal Server Error java.lang.IllegalArgumentException: Source may not be null at webwork.util.SubsetIteratorFilter.setSource(SubsetIteratorFilter.java:33) at webwork.view.taglib.iterator.SubsetIteratorTag.doStartTag(SubsetIteratorTag.java:66) at /secure/views/dashboard.jsp._jspService(/secure/views/dashboard.jsp.java:2214) (JSP page line 411) at com.orionserver[Orion/1.5.4 (build 10585)].http.OrionHttpJspPage.service(.:56) at com.evermind[Orion/1.5.4 (build 10585)]._cp._vhc(.:5639) at com.evermind[Orion/1.5.4 (build 10585)].server.http.JSPServlet.service(.:31) at com.evermind[Orion/1.5.4 (build 10585)]._ie.doFilter(.:59) at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(Unknown Source) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:16) at com.atlassian.jira.web.security.SecurityFilter.doFilter(SecurityFilter.java:132) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.jira.web.security.LoginFilter.doFilter(LoginFilter.java:115) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.util.filters.ProfilingFilter.doFilter(Unknown Source) at com.evermind[Orion/1.5.4 (build 10585)]._deb._lnc(.:376) at com.evermind[Orion/1.5.4 (build 10585)]._deb._wmb(.:170) at com.evermind[Orion/1.5.4 (build 10585)]._deb.forward(.:141) at webwork.dispatcher.ServletDispatcher.service(ServletDispatcher.java:287) at javax.servlet.http.HttpServlet.service(HttpServlet.java:336) at com.evermind[Orion/1.5.4 (build 10585)]._ie.doFilter(.:59) at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(Unknown Source) at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(Unknown Source) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:16) at com.atlassian.jira.web.security.SecurityFilter.doFilter(SecurityFilter.java:208) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.jira.web.security.LoginFilter.doFilter(LoginFilter.java:194) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.util.filters.ProfilingFilter.doFilter(Unknown Source)at com.evermind[Orion/1.5.4 (build 10585)]._deb._lnc(.:376) at com.evermind[Orion/1.5.4 (build 10585)]._deb._wmb(.:170) at com.evermind[Orion/1.5.4 (build 10585)]._co._wbb(.:581) at com.evermind[Orion/1.5.4 (build 10585)]._co._fs(.:189) at com.evermind[Orion/1.5.4 (build 10585)]._bt.run(.:62) Per Mike's recommendation, I created an issue, assigned it to myself and then marked the issue In Progress. I logged out and then back in again and still got the above error when displaying the dashboard. And when I clicked on Browse Project, the Summary displays the correct numbers, including one In Progress Issue. Then, if I click on any of the links to the IssueNavigator, I get the following error: 500 Internal Server Error java.lang.VerifyError: (class: com/atlassian/jira/issue/search/SearchRequest, method: init signature: (Lelectric/xml/Document;)V) Incompatible object argument for function call at com.atlassian.jira.issue.search.SearchRequestFactory.create(SearchRequestFactory.java:131) at com.atlassian.jira.web.action.issue.IssueNavigator.doExecute(IssueNavigator.java:98) at webwork.action.ActionSupport.execute(ActionSupport.java:108) at webwork.dispatcher.ServletDispatcher.service(ServletDispatcher.java:220) at javax.servlet.http.HttpServlet.service(HttpServlet.java:336) at com.evermind[Orion/1.5.4 (build 10585)]._ie.doFilter(.:59) at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(Unknown Source) at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(Unknown Source) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:16) at com.atlassian.jira.web.security.SecurityFilter.doFilter(SecurityFilter.java:208) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.jira.web.security.LoginFilter.doFilter(LoginFilter.java:194) at com.evermind[Orion/1.5.4 (build 10585)]._ic.doFilter(.:20) at com.atlassian.util.filters.ProfilingFilter.doFilter(Unknown Source) at com.evermind[Orion/1.5.4 (build 10585)]._deb._lnc(.:376) at com.evermind[Orion/1.5.4 (build 10585)]._deb._wmb(.:170) at com.evermind[Orion/1.5.4 (build 10585)]._co._wbb(.:581) at com.evermind[Orion/1.5.4 (build 10585)]._co._fs(.:189) at com.evermind[Orion/1.5.4 (build 10585)]._bt.run(.:62) The following is displayed in the console window back on the server: ((I get the no descriptor found error whenever I click on a link to filter) Orion/1.5.4 initialized not adding appender do nothing - assume already setup 2002-06-21 11:31:48,058 WARN [webwork.dispatcher.ServletDispatcher] Unable to find 'webwork.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir 2002-06-21 11:31:48,058 WARN [webwork.dispatcher.ServletDispatcher] Unable to find 'webwork.multipart.saveDir' property setting. Defaulting to javax.servlet.context.tempdir 2002-06-21 11:31:48,602 FATAL [core.entity.model.ModelReader] FINISHED LOADING ENTITIES - ALL FILES; #Entities=23 #ViewEntities=0 #Fields=106 #Relationships=14 [Filter: profiling] Using parameter [jira_profile] [2905ms] - /jira13/Dashboard.jspa [2076ms] - /jira13/secure/views/dashboard.jsp [411ms] - /jira13/decorators/main.jsp [30ms] - /jira13/decorators/panels/navitem.jsp [1ms] - /jira13/decorators/panels/navitem.jsp [1ms] - /jira13/decorators/panels/navitem.jsp [1ms] - /jira13/decorators/panels/navitem.jsp [70ms] - /jira13/login.jsp [26ms] - /jira13/decorators/frontpage.jsp [80ms] - /jira13/login.jsp [145ms] - /jira13/secure/default.jsp [444ms] - /jira13/secure/Dashboard.jspa [391ms] - /jira13/secure/views/dashboard.jsp [47ms] - /jira13/decorators/main.jsp [1ms] - /jira13/decorators/panels/navitem.jsp [0ms] - /jira13/decorators/panels/navitem.jsp [0ms] - /jira13/decorators/panels/navitem.jsp [1ms] - /jira13/decorators/panels/navitem.jsp [0ms] - /jira13/decorators/panels/navitem.jsp 2002-06-21 11:33:17,291 WARN [webwork.util.BeanUtil] No descriptor found for. Unable to set value. 2002-06-21 11:33:17,291 WARN [webwork.util.BeanUtil] No descriptor found for. Unable to set value. I can perform any of the Administrator functions, and if I know the key for an issue, I can go directly to that issue and view/edit/resolve/comment it. Per Mike's suggestion, I changed to a hsql data source, went through the setup and then recieved the same error messages.

    Atlassian JIRA | 1 decade ago | Robin Anders
    java.lang.IllegalArgumentException: Source may not be null
  2. Speed up your debug routine!

    Automated exception search integrated into your IDE

  3. 0

    titan, loading data with batchgraph

    Stack Overflow | 1 year ago | AgonyClanKios
    java.lang.IllegalArgumentException: Graph may not be null
  4. 0

    Apache HttpClientBuilder - IllegalArgumentException

    Stack Overflow | 2 years ago | k_wisniewski
    java.lang.IllegalArgumentException: Item may not be null

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.IllegalArgumentException

      Source may not be null

      at webwork.util.SubsetIteratorFilter.setSource()
    2. webwork.util
      SubsetIteratorFilter.setSource
      1. webwork.util.SubsetIteratorFilter.setSource(SubsetIteratorFilter.java:33)
      1 frame
    3. webwork.view.taglib
      SubsetIteratorTag.doStartTag
      1. webwork.view.taglib.iterator.SubsetIteratorTag.doStartTag(SubsetIteratorTag.java:66)
      1 frame
    4. org.apache.jsp
      dashboard$jsp._jspService
      1. org.apache.jsp.dashboard$jsp._jspService(dashboard$jsp.java:3498)
      1 frame