com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed. (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed.) (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed. (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed.))

Oracle Community | 807567 | 9 years ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Phobos Deploy problem

    Oracle Community | 9 years ago | 807567
    com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed. (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed.) (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed. (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed.))
  2. 0

    Using JSP with Embedded Jetty 7 in Eclipse IDE, getting LogConfigurationException

    Stack Overflow | 6 years ago | gcstang
    com.sun.org.apache.commons.logging.LogConfigurationException: com.sun.org.apache.commons.logging.LogConfigurationException: java.lang.NullPointerException (Caused by java.lang.NullPointerException) (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: java.lang.NullPointerException (Caused by java.lang.NullPointerException))

    Root Cause Analysis

    1. com.sun.org.apache.commons.logging.LogConfigurationException

      com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed. (Caused by com.sun.org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. You have more than one version of 'com.sun.org.apache.commons.logging.Log' visible, which is not allowed.)

      at com.sun.org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor()
    2. Glassfish Jasper
      LogFactoryImpl.newInstance
      1. com.sun.org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:397)
      2. com.sun.org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:529)
      2 frames