com.atlassian.plugin.osgi.container.OsgiContainerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • h3. *Problem Statement* What's New plugin is not enabled upon startup. After startup, it cannot be manually enabled as well. h3. *Environment* - Confluence 5.9.1 (64bit Installer) - Bundled confluence-whats-new-6.10.2 h3. *Diagnosis* The following stack trace is found in the logs. Clearing the plugin cache doesn't work. Confluence-whats-new-6.7 is working in Confluence 5.8.17. {code} 2015-11-27 18:37:35,044 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugin 'com.atlassian.confluence.plugins.whatsnew' : Unresolved constraint in bundle com.atlassian.confluence.plugins.confluence-whats-new [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.plugin.descriptor.web.conditions)(version>=5.9.1.OD-65-004)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2015-11-27 18:37:35,044 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 'com.atlassian.confluence.plugins.whatsnew' 2015-11-27 18:37:35,045 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.plugins.whatsnew at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:407) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.lateStartup(DefaultPluginManager.java:536) at com.atlassian.confluence.plugin.ConfluencePluginManager.lateStartup(ConfluencePluginManager.java:157) at com.atlassian.confluence.plugin.PluginFrameworkContextListener.contextInitialized(PluginFrameworkContextListener.java:88) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4729) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5167) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1409) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1399) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.plugins.confluence-whats-new [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.plugin.descriptor.web.conditions)(version>=5.9.1.OD-65-004)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:388) ... 17 more {code} h3. *Solution* Upgrade to Confluence 5.9.2
    via by Victor Teoh [Atlassian],
  • h3. *Problem Statement* What's New plugin is not enabled upon startup. After startup, it cannot be manually enabled as well. h3. *Environment* - Confluence 5.9.1 (64bit Installer) - Bundled confluence-whats-new-6.10.2 h3. *Diagnosis* The following stack trace is found in the logs. Clearing the plugin cache doesn't work. Confluence-whats-new-6.7 is working in Confluence 5.8.17. {code} 2015-11-27 18:37:35,044 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugin 'com.atlassian.confluence.plugins.whatsnew' : Unresolved constraint in bundle com.atlassian.confluence.plugins.confluence-whats-new [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.plugin.descriptor.web.conditions)(version>=5.9.1.OD-65-004)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2015-11-27 18:37:35,044 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 'com.atlassian.confluence.plugins.whatsnew' 2015-11-27 18:37:35,045 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.plugins.whatsnew at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:407) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.lateStartup(DefaultPluginManager.java:536) at com.atlassian.confluence.plugin.ConfluencePluginManager.lateStartup(ConfluencePluginManager.java:157) at com.atlassian.confluence.plugin.PluginFrameworkContextListener.contextInitialized(PluginFrameworkContextListener.java:88) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4729) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5167) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1409) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1399) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.plugins.confluence-whats-new [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.plugin.descriptor.web.conditions)(version>=5.9.1.OD-65-004)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:388) ... 17 more {code} h3. *Solution* Upgrade to Confluence 5.9.2
    via by Victor Teoh [Atlassian],
  • Confluence Macro with external database driver
    via Stack Overflow by Hauke
    ,
  • Cannot load FaCT++ reasoner
    via GitHub by AndreyMZ
    ,
  • Using Service Component Runtime
    via Stack Overflow by Stas Kurilin
    ,
    • com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.plugins.whatsnew at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:407) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:286) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:130) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:107) at com.atlassian.plugin.manager.DefaultPluginManager.enableDependentPlugins(DefaultPluginManager.java:1079) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1055) at com.atlassian.plugin.manager.DefaultPluginManager.lateStartup(DefaultPluginManager.java:536) at com.atlassian.confluence.plugin.ConfluencePluginManager.lateStartup(ConfluencePluginManager.java:157) at com.atlassian.confluence.plugin.PluginFrameworkContextListener.contextInitialized(PluginFrameworkContextListener.java:88) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4729) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5167) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1409) at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1399) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.plugins.confluence-whats-new [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package; (&(osgi.wiring.package=com.atlassian.confluence.plugin.descriptor.web.conditions)(version>=5.9.1.OD-65-004)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:388) ... 17 more

    Users with the same issue

    davidvanlaatum
    28 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    16 more bugmates