java.lang.AssertionError

ERROR: An invalid state transition was requested in module UMSJMSSystemResource for entity OraSDPM/QueueConnectionFactory. The transition requested was from ACTIVE to INITIALIZED

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web7062

  • via Oracle Community by SivaBalan19, 11 months ago
    ERROR: An invalid state transition was requested in module UMSJMSSystemResource for entity OraSDPM/QueueConnectionFactory. The transition requested was from ACTIVE to INITIALIZED
  • via javamonamour.org by Unknown author, 1 year ago
    Invalid state transition from failed to stable_leader
  • via Oracle Community by 919404, 1 year ago
    Invalid state transition from stable_leader to stable
  • Stack trace

    • java.lang.AssertionError: ERROR: An invalid state transition was requested in module UMSJMSSystemResource for entity OraSDPM/QueueConnectionFactory. The transition requested was from ACTIVE to INITIALIZED at weblogic.jms.module.JMSModule$EntityState.invalidStateTransition(JMSModule.java:1660) at weblogic.jms.module.JMSModule$EntityState.setState(JMSModule.java:1698) at weblogic.jms.module.JMSModule$EntityState.setState(JMSModule.java:1667) at weblogic.jms.module.JMSModule$EntityState.access$100(JMSModule.java:1608) at weblogic.jms.module.JMSModule.unprepare(JMSModule.java:462) at weblogic.jms.module.ModuleCoordinator.unprepare(ModuleCoordinator.java:378) at weblogic.application.internal.flow.ModuleListenerInvoker.unprepare(ModuleListenerInvoker.java:285) at weblogic.application.internal.flow.DeploymentCallbackFlow$1.previous(DeploymentCallbackFlow.java:523) at weblogic.application.utils.StateMachineDriver.previousState(StateMachineDriver.java:223) at weblogic.application.utils.StateMachineDriver.previousState(StateMachineDriver.java:215) at weblogic.application.internal.flow.DeploymentCallbackFlow.unprepare(DeploymentCallbackFlow.java:211) at weblogic.application.internal.flow.DeploymentCallbackFlow.unprepare(DeploymentCallbackFlow.java:202) at weblogic.application.internal.BaseDeployment$1.previous(BaseDeployment.java:654) at weblogic.application.utils.StateMachineDriver.previousState(StateMachineDriver.java:223) at weblogic.application.utils.StateMachineDriver.previousState(StateMachineDriver.java:215) at weblogic.application.internal.BaseDeployment.unprepare(BaseDeployment.java:255) at weblogic.application.internal.SingleModuleDeployment.unprepare(SingleModuleDeployment.java:44) at weblogic.application.internal.DeploymentStateChecker.unprepare(DeploymentStateChecker.java:205) at weblogic.deploy.internal.targetserver.AppContainerInvoker.unprepare(AppContainerInvoker.java:117) at weblogic.deploy.internal.targetserver.BasicDeployment.unprepare(BasicDeployment.java:287) at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:363) at weblogic.management.deploy.internal.DeploymentAdapter$1.doPrepare(DeploymentAdapter.java:42) at weblogic.management.deploy.internal.DeploymentAdapter.prepare(DeploymentAdapter.java:191) at weblogic.management.deploy.internal.AppTransition$1.transitionApp(AppTransition.java:21) at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:240) at weblogic.management.deploy.internal.ConfiguredDeployments.prepare(ConfiguredDeployments.java:165) at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:122) at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180) at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96) at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64) at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256) at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago