java.io.IOException

Cannot run program "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK\jdk.exe" (in directory "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK"): CreateProcess error=193, %1 is not a valid Win32 application

Samebug tips1

This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web26254

  • via Jenkins JIRA by himanshu k, 11 months ago
    Cannot run program "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK\jdk.exe" (in directory "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK"): CreateProcess error=193, %1 is not a valid Win32 application
  • Cannot run program "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK\jdk.exe" (in directory "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK"): CreateProcess error=193, %1 is not a valid Win32 application
  • via Jenkins JIRA by himanshu k, 1 year ago
    Cannot run program "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK\jdk.exe" (in directory "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK"): CreateProcess error=193, %1 is not a valid Win32 application
  • Stack trace

    • java.io.IOException: Cannot run program "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK\jdk.exe" (in directory "C:\Program Files (x86)\Jenkins\tools\hudson.model.JDK"): CreateProcess error=193, %1 is not a valid Win32 application at java.lang.ProcessBuilder.start(Unknown Source) at hudson.Proc$LocalProc.<init>(Proc.java:244) at hudson.Proc$LocalProc.<init>(Proc.java:216) at hudson.Launcher$LocalLauncher.launch(Launcher.java:816) at hudson.Launcher$ProcStarter.start(Launcher.java:382) at hudson.Launcher$ProcStarter.join(Launcher.java:389) at hudson.tools.JDKInstaller.install(JDKInstaller.java:268) at hudson.tools.JDKInstaller.performInstallation(JDKInstaller.java:141) at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:68) at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:108) at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:206) at hudson.model.JDK.forNode(JDK.java:143) at hudson.model.AbstractProject.getEnvironment(AbstractProject.java:358) at hudson.model.Run.getEnvironment(Run.java:2232) at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:941) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1036) at hudson.scm.SCM.checkout(SCM.java:485) at hudson.model.AbstractProject.checkout(AbstractProject.java:1275) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:610) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532) at hudson.model.Run.execute(Run.java:1741) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Caused by: java.io.IOException: CreateProcess error=193, %1 is not a valid Win32 application at java.lang.ProcessImpl.create(Native Method) at java.lang.ProcessImpl.<init>(Unknown Source) at java.lang.ProcessImpl.start(Unknown Source) ... 25 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 7 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    161 more bugmates