org.osgi.framework.BundleException

Could not resolve module: org.eclipse.pde.api.tools.tests [267] Unresolved requirement: Require-Bundle: org.eclipse.test.performance

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web6466

  • via eclipse.org by Unknown author, 11 months ago
    Could not resolve module: org.eclipse.pde.api.tools.tests [267] Unresolved requirement: Require-Bundle: org.eclipse.test.performance
  • via fordiac by niko87
    , 1 year ago
    Could not resolve module: org.eclipse.xtext.common.types [332] Unresolved requirement: Require-Bundle: com.google.inject; bundle-version="3.0.0"
  • via eclipse.org by Unknown author, 11 months ago
    Could not resolve module: org.eclipse.emf.importer.java [70] Unresolved requirement: Require-Bundle: org.eclipse.core.resources; bundle-version="[3.5.0,4.0.0)"
  • Stack trace

    • org.osgi.framework.BundleException: Could not resolve module: org.eclipse.pde.api.tools.tests [267] Unresolved requirement: Require-Bundle: org.eclipse.test.performance at org.eclipse.osgi.container.Module.start(Module.java:444) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 10 months ago
    Unknown user
    2 times, 10 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 11 months ago
    43 more bugmates