java.lang.InterruptedException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • The WebSphere Deployer plugin is able to connect to the remote WAS 8.5.5.5 server, and stop/remove/install a WAR/EAR. I can see the new app shows up on the WAS console as stopped, and the following line in the SystemOut.log ADMA5013I: Application HelloWorldServlet installed successfully. But the build just hung there forever, not able to start the app, and no error in the remote server log, only found the following error in the Jenkins log until I cancel the build: Nov 13, 2015 8:11:36 AM hudson.model.Run execute INFO: Test Project #26 main build action completed: SUCCESS Nov 13, 2015 8:11:36 AM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props java.lang.InterruptedException at java.lang.Object.wait(Native Method) at java.lang.Object.wait(Unknown Source) at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:270) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to updated artifact: null at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:278) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) thanks. java9394
    via by Java Guy,
  • The WebSphere Deployer plugin is able to connect to the remote WAS 8.5.5.5 server, and stop/remove/install a WAR/EAR. I can see the new app shows up on the WAS console as stopped, and the following line in the SystemOut.log ADMA5013I: Application HelloWorldServlet installed successfully. But the build just hung there forever, not able to start the app, and no error in the remote server log, only found the following error in the Jenkins log until I cancel the build: Nov 13, 2015 8:11:36 AM hudson.model.Run execute INFO: Test Project #26 main build action completed: SUCCESS Nov 13, 2015 8:11:36 AM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props java.lang.InterruptedException at java.lang.Object.wait(Native Method) at java.lang.Object.wait(Unknown Source) at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:270) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to updated artifact: null at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:278) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) thanks. java9394
    via by Java Guy,
  • Unable to start Jenkins
    via Stack Overflow by P.K.S
    ,
    • java.lang.InterruptedException at java.lang.Object.wait(Native Method) at java.lang.Object.wait(Unknown Source) at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:270) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410)

    Users with the same issue

    Agócs TamásAgócs Tamás
    4 times, last one,
    AravindAravind
    2 times, last one,
    batwalrus76batwalrus76
    1 times, last one,
    danleyb2Interinteldanleyb2Interintel
    1 times, last one,
    filpgamefilpgame
    1 times, last one,
    36 more bugmates