java.lang.ClassNotFoundException: oracle.jrf.AppContextStartup


Samebug tips

This might be an issue with the file location in the Spark submit command. Try it with

spark-submit --master spark://master:7077 \
     hello_world_from_pyspark.py {file location}


7 months ago
Expert tip

Check if you've set a name in Application -> Run. If you didn't, the generated XML is gonna have missing information and then this exception will be thrown.


6 months ago
Expert tip

Solutions on the web

Solution icon of oraclecommunity
via Oracle Community by 801156, 1 year ago
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
via Oracle Community by Imran Mirza, 1 year ago
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
via Oracle Community by Prasad K T, 11 months ago
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
oracle.jrf.AppContextStartup

Solution icon of web
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
via Oracle Community by 797230, 1 year ago
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
via Oracle Community by 1000796, 1 year ago
oracle.jrf.AppContextStartup

Solution icon of oraclecommunity
via Oracle Community by 1000796, 1 year ago
oracle.jrf.AppContextStartup

Stack trace

java.lang.ClassNotFoundException: oracle.jrf.AppContextStartup
	at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:303)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:247)
	at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:262)
	at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54)
	at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:214)
	at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
	at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
	at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClassDeployment(ClassDeploymentManager.java:246)
	at weblogic.management.deploy.classdeployment.ClassDeploymentManager.runStartupsBeforeAppDeployments(ClassDeploymentManager.java:149)
	at weblogic.management.deploy.classdeployment.ClassDeploymentService.start(ClassDeploymentService.java:21)
	at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
	at weblogic.work.SelfTuningWorkManagerImpl$WorkAdapterImpl.run(SelfTuningWorkManagerImpl.java:528)
	at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
	at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
4 times, 3 hours ago
394 times, 21 hours ago
2 times, 1 week ago
209 times, 1 week ago
1403 more bugmates