java.io.IOException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • When trying to install the latest (version 1.2) Amazon ECS Container Service plugin, I get the following error. It seems to be related to some recent updates. Several weeks ago with version 1.1 of the Amazon ECS Container Service plugin it installed without issue. I was trying to install the plugin on a fresh EC2 instance with only OpenJDK and Jenkins installed. Looking at https://wiki.jenkins-ci.org/display/JENKINS/Amazon+EC2+Container+Service+Plugin, aws-credentials is listed as a dependency but is not a hyperlink. Searching for the aws-credentials plugin on jenkins-ci.org brings up https://wiki.jenkins-ci.org/display/JENKINS/CloudBees+AWS+Credentials+Plugin. Searching in jenkins does not bring up any results. If I do some searching I can find the github repo (https://github.com/jenkinsci/aws-credentials-plugin) for aws-credentials which links to https://wiki.jenkins-ci.org/display/JENKINS/CloudBees+Amazon+Web+Services+Credentials+Plugin, which is a different page then above. {code} java.io.IOException: Failed to dynamically deploy this plugin at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1383) at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1161) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask.run(FutureTask.java:262) at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110) at java.lang.Thread.run(Thread.java:745) Caused by: java.io.IOException: Failed to install amazon-ecs plugin at hudson.PluginManager.dynamicLoad(PluginManager.java:487) at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1379) ... 5 more Caused by: java.io.IOException: Dependency aws-credentials (1.10) doesn't exist at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:533) at hudson.PluginManager.dynamicLoad(PluginManager.java:477) ... 6 more {code}
    via by Chris Zeeb,
  • When trying to install the latest (version 1.2) Amazon ECS Container Service plugin, I get the following error. It seems to be related to some recent updates. Several weeks ago with version 1.1 of the Amazon ECS Container Service plugin it installed without issue. I was trying to install the plugin on a fresh EC2 instance with only OpenJDK and Jenkins installed. Looking at https://wiki.jenkins-ci.org/display/JENKINS/Amazon+EC2+Container+Service+Plugin, aws-credentials is listed as a dependency but is not a hyperlink. Searching for the aws-credentials plugin on jenkins-ci.org brings up https://wiki.jenkins-ci.org/display/JENKINS/CloudBees+AWS+Credentials+Plugin. Searching in jenkins does not bring up any results. If I do some searching I can find the github repo (https://github.com/jenkinsci/aws-credentials-plugin) for aws-credentials which links to https://wiki.jenkins-ci.org/display/JENKINS/CloudBees+Amazon+Web+Services+Credentials+Plugin, which is a different page then above. {code} java.io.IOException: Failed to dynamically deploy this plugin at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1383) at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1161) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask.run(FutureTask.java:262) at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110) at java.lang.Thread.run(Thread.java:745) Caused by: java.io.IOException: Failed to install amazon-ecs plugin at hudson.PluginManager.dynamicLoad(PluginManager.java:487) at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1379) ... 5 more Caused by: java.io.IOException: Dependency aws-credentials (1.10) doesn't exist at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:533) at hudson.PluginManager.dynamicLoad(PluginManager.java:477) ... 6 more {code}
    via by Chris Zeeb,
  • Error on install
    via GitHub by renekorss
    ,
  • Can't download plugins - HTTP 302 redirect
    via by Corey Wei,
    • java.io.IOException: Failed to dynamically deploy this plugin at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1383) at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1161) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask.run(FutureTask.java:262) at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110) at java.lang.Thread.run(Thread.java:745) Caused by: java.io.IOException: Failed to install amazon-ecs plugin at hudson.PluginManager.dynamicLoad(PluginManager.java:487) at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1379) ... 5 more Caused by: java.io.IOException: Dependency aws-credentials (1.10) doesn't exist at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:533) at hudson.PluginManager.dynamicLoad(PluginManager.java:477) ... 6 more

    Users with the same issue

    Unknown visitor
    Unknown visitor2 times, last one,
    Unknown visitor
    Unknown visitor2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    davidvanlaatumdavidvanlaatum
    14 times, last one,
    23 more bugmates