net.sf.json.JSONException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Get the following error no matter how I configured creds (no creds with job token, username with token, or using a username/password creds file). ERROR: Build step failed with exception net.sf.json.JSONException: JSONArray[0] is not a JSONObject. at net.sf.json.JSONArray.getJSONObject(JSONArray.java:1977) at org.jenkinsci.plugins.ParameterizedRemoteTrigger.RemoteBuildConfiguration.perform(RemoteBuildConfiguration.java:563) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.Build$BuildExecution.build(Build.java:205) at hudson.model.Build$BuildExecution.doRun(Build.java:162) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534) at hudson.model.Run.execute(Run.java:1738) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Build step 'Trigger a remote parameterized job' marked build as failure It seems Jenkins no longer returning properly formed JSON when jobs are triggered. There's nothing in the jenkins.log on the machine receiving the request to trigger a build but the build does in fact get triggered and start. The issue is on the sending side. This stack trace causes the build to fail and breaks builds, otherwise it would be easy to ignore. I confirmed that I can remote trigger jobs by hand hitting the URL in the various forms but also confirmed there's no response back whatsoever other than a response "201" (created). There's no body or other payload in the response. I should note this failure started upon upgrading to 1.653 from 1.618 (it was previously working just fine on the same version of the plugin). I've confirmed this problem exists on a fresh install as well.
    via by Maxfield Stewart,
  • Get the following error no matter how I configured creds (no creds with job token, username with token, or using a username/password creds file). ERROR: Build step failed with exception net.sf.json.JSONException: JSONArray[0] is not a JSONObject. at net.sf.json.JSONArray.getJSONObject(JSONArray.java:1977) at org.jenkinsci.plugins.ParameterizedRemoteTrigger.RemoteBuildConfiguration.perform(RemoteBuildConfiguration.java:563) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.Build$BuildExecution.build(Build.java:205) at hudson.model.Build$BuildExecution.doRun(Build.java:162) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534) at hudson.model.Run.execute(Run.java:1738) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Build step 'Trigger a remote parameterized job' marked build as failure It seems Jenkins no longer returning properly formed JSON when jobs are triggered. There's nothing in the jenkins.log on the machine receiving the request to trigger a build but the build does in fact get triggered and start. The issue is on the sending side. This stack trace causes the build to fail and breaks builds, otherwise it would be easy to ignore. I confirmed that I can remote trigger jobs by hand hitting the URL in the various forms but also confirmed there's no response back whatsoever other than a response "201" (created). There's no body or other payload in the response. I should note this failure started upon upgrading to 1.653 from 1.618 (it was previously working just fine on the same version of the plugin). I've confirmed this problem exists on a fresh install as well.
    via by Maxfield Stewart,
    • net.sf.json.JSONException: JSONArray[0] is not a JSONObject. at net.sf.json.JSONArray.getJSONObject(JSONArray.java:1977) at org.jenkinsci.plugins.ParameterizedRemoteTrigger.RemoteBuildConfiguration.perform(RemoteBuildConfiguration.java:563) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.Build$BuildExecution.build(Build.java:205) at hudson.model.Build$BuildExecution.doRun(Build.java:162) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534) at hudson.model.Run.execute(Run.java:1738) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410)

    Users with the same issue

    DoktorDoener666DoktorDoener666
    1 times, last one,
    Unknown visitor
    Unknown visitor2 times, last one,