Pattern selector

Most relevant patterns first. Most helpful ones displayed. Click here to show all.

  1. ClassLoader.loadClass() has thrown an UnsupportedClassVersionError
    Java Runtime
    162
    366
    38
  2. ClassLoader.defineClass() has thrown an UnsupportedClassVersionError
    Java Runtime
    433
    770
    233

Your stack trace compared to the selected pattern

Jump to solutionsExpand frames
java.lang.UnsupportedClassVersionError: org/sireum/util/FileUtil$ : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
28 frames hidden

Solution

Shane Rogers11 months ago

This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Check the source of this solution for more info

External results for this pattern (10)

  1. java.lang.UnsupportedClassVersionError: net/dzikoysk/funnyguilds/FunnyGuilds : Unsupported major.minor version 52.0
    Show stack trace
  2. xPiwkoPLvia GitHub1 day ago
    java.lang.UnsupportedClassVersionError: net/dzikoysk/funnyguilds/FunnyGuilds : Unsupported major.minor version 52.0
    Show stack trace
  3. filipqwvia GitHub1 day ago
    java.lang.UnsupportedClassVersionError: net/dzikoysk/funnyguilds/FunnyGuilds : Unsupported major.minor version 51.0
    Show stack trace
  4. ALISTAR1234via GitHub1 day ago
    org/panda_lang/panda/util/configuration/PandaConfiguration : Unsupported major.minor version 52.0
    Show stack trace
  5. achyuthrbtvia GitHub1 day ago
    No message found for this stack trace.
    Show stack trace
  6. MareoRaftvia GitHub2 days ago
    stringtruncate/StringTruncate : Unsupported major.minor version 52.0
    Show stack trace
  7. rbg2024via GitHub3 days ago
    org/rpi/main/StartMe : Unsupported major.minor version 52.0
    Show stack trace
  8. dbosanziovia GitHub3 days ago
    No message found for this stack trace.
    Show stack trace
  9. carepackvia GitHub3 days ago
    org/malai/swing/ui/SwingUI : Unsupported major.minor version 52.0
    Show stack trace