java.lang.IllegalStateException: ClobStringType requires active transaction synchronization

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Atlassian JIRA by Geoffrey Wiseman, 1 year ago
ClobStringType requires active transaction synchronization
via Atlassian JIRA by Geoffrey Wiseman, 1 year ago
ClobStringType requires active transaction synchronization
via Ecosystem JIRA by Jonathan Appel, 1 year ago
ClobStringType requires active transaction synchronization
java.lang.IllegalStateException: ClobStringType requires active transaction synchronization
at bucket.util.BucketClobStringType.nullSafeSet(BucketClobStringType.java:127)
at net.sf.hibernate.type.CustomType.nullSafeSet(CustomType.java:118)
at net.sf.hibernate.persister.EntityPersister.dehydrate(EntityPersister.java:387)
at net.sf.hibernate.persister.EntityPersister.update(EntityPersister.java:642)
at net.sf.hibernate.persister.EntityPersister.update(EntityPersister.java:621)
at net.sf.hibernate.impl.ScheduledUpdate.execute(ScheduledUpdate.java:52)
at net.sf.hibernate.impl.SessionImpl.execute(SessionImpl.java:2449)
at net.sf.hibernate.impl.SessionImpl.executeAll(SessionImpl.java:2435)
at net.sf.hibernate.impl.SessionImpl.execute(SessionImpl.java:2393)
at net.sf.hibernate.impl.SessionImpl.flush(SessionImpl.java:2261)
at com.atlassian.confluence.util.AncestorTableBuilder.build(AncestorTableBuilder.java:48)
at com.atlassian.confluence.upgrade.PagePermissionUpgradeTask.updateDatabase(PagePermissionUpgradeTask.java:51)
at com.atlassian.confluence.upgrade.PagePermissionUpgradeTask.doUpgrade(PagePermissionUpgradeTask.java:38)
at bucket.upgrade.AbstractUpgradeManager.doUpgrade(AbstractUpgradeManager.java:103)
at bucket.upgrade.AbstractUpgradeManager.upgrade(AbstractUpgradeManager.java:63)
at bucket.upgrade.UpgradeLauncherServletContextListener.contextInitialized(UpgradeLauncherServletContextListener.java:27)
at com.atlassian.confluence.upgrade.ConfluenceUpgradeServletContextListener.contextInitialized(ConfluenceUpgradeServletContextListener.java:14)

Users with the same issue

You are the first who have seen this exception.

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.