java.io.IOException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • After upgrading from version 0.0.8 to 0.0.9 of this plugin, the Jenkins UI fails to load upon restart. The "Jenkins" service is running but serves no content to browsers. The error log shows the following stack trace: Dec 17, 2015 7:59:54 AM jenkins.InitReactorRunner$1 onTaskFailed SEVERE: Failed Loading plugin scm-sync-configuration java.io.IOException: Failed to initialize at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441) at hudson.PluginManager$2$1$1.run(PluginManager.java:371) at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282) at jenkins.model.Jenkins$7.runTask(Jenkins.java:905) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.NullPointerException at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(Unknown Source) at sun.reflect.UnsafeQualifiedObjectFieldAccessorImpl.get(Unknown Source) at java.lang.reflect.Field.get(Unknown Source) at hudson.plugins.scm_sync_configuration.scms.ScmSyncSubversionSCM.extractScmCredentials(ScmSyncSubversionSCM.java:59) at hudson.plugins.scm_sync_configuration.scms.SCM.getConfiguredRepository(SCM.java:66) at hudson.plugins.scm_sync_configuration.SCMManipulator.scmConfigurationSettledUp(SCMManipulator.java:57) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.initializeRepository(ScmSyncConfigurationBusiness.java:72) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.init(ScmSyncConfigurationBusiness.java:67) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.initialInit(ScmSyncConfigurationPlugin.java:174) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.start(ScmSyncConfigurationPlugin.java:157) at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449) at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438) ... 9 more Manually downgrading the scm-sync-configuration plugin to 0.0.8 and restarting solves the problem. I've done this upgrade/downgrade cycle twice to confirm that this is indeed the cause.
    via by Nick Jones,
  • After upgrading from version 0.0.8 to 0.0.9 of this plugin, the Jenkins UI fails to load upon restart. The "Jenkins" service is running but serves no content to browsers. The error log shows the following stack trace: Dec 17, 2015 7:59:54 AM jenkins.InitReactorRunner$1 onTaskFailed SEVERE: Failed Loading plugin scm-sync-configuration java.io.IOException: Failed to initialize at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441) at hudson.PluginManager$2$1$1.run(PluginManager.java:371) at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282) at jenkins.model.Jenkins$7.runTask(Jenkins.java:905) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.NullPointerException at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(Unknown Source) at sun.reflect.UnsafeQualifiedObjectFieldAccessorImpl.get(Unknown Source) at java.lang.reflect.Field.get(Unknown Source) at hudson.plugins.scm_sync_configuration.scms.ScmSyncSubversionSCM.extractScmCredentials(ScmSyncSubversionSCM.java:59) at hudson.plugins.scm_sync_configuration.scms.SCM.getConfiguredRepository(SCM.java:66) at hudson.plugins.scm_sync_configuration.SCMManipulator.scmConfigurationSettledUp(SCMManipulator.java:57) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.initializeRepository(ScmSyncConfigurationBusiness.java:72) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.init(ScmSyncConfigurationBusiness.java:67) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.initialInit(ScmSyncConfigurationPlugin.java:174) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.start(ScmSyncConfigurationPlugin.java:157) at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449) at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438) ... 9 more Manually downgrading the scm-sync-configuration plugin to 0.0.8 and restarting solves the problem. I've done this upgrade/downgrade cycle twice to confirm that this is indeed the cause.
    via by Nick Jones,
  • Jenkins gives me blank page
    via Stack Overflow by guylifestyle
    ,
  • Crash - Pastey.org
    via by Unknown author,
    • java.io.IOException: Failed to initialize at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441) at hudson.PluginManager$2$1$1.run(PluginManager.java:371) at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169) at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282) at jenkins.model.Jenkins$7.runTask(Jenkins.java:905) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.NullPointerException at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(Unknown Source) at sun.reflect.UnsafeQualifiedObjectFieldAccessorImpl.get(Unknown Source) at java.lang.reflect.Field.get(Unknown Source) at hudson.plugins.scm_sync_configuration.scms.ScmSyncSubversionSCM.extractScmCredentials(ScmSyncSubversionSCM.java:59) at hudson.plugins.scm_sync_configuration.scms.SCM.getConfiguredRepository(SCM.java:66) at hudson.plugins.scm_sync_configuration.SCMManipulator.scmConfigurationSettledUp(SCMManipulator.java:57) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.initializeRepository(ScmSyncConfigurationBusiness.java:72) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness.init(ScmSyncConfigurationBusiness.java:67) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.initialInit(ScmSyncConfigurationPlugin.java:174) at hudson.plugins.scm_sync_configuration.ScmSyncConfigurationPlugin.start(ScmSyncConfigurationPlugin.java:157) at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449) at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438) ... 9 more

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown User
    2 times, last one,
    adawolfs
    4 times, last one,
    3 more bugmates