Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Jenkins JIRA by srijini s, 2 years ago
Unable to determine Maven version
via jenkins-ci.org by Unknown author, 1 year ago
via Jenkins JIRA by Giuliano Ribeiro, 2 years ago
Unable to determine Maven version
via Jenkins JIRA by Giuliano Ribeiro, 1 year ago
Unable to determine Maven version
java.lang.RuntimeException: Unable to determine Maven version at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.isMavenVersionValid(MavenExtractorEnvironment.java:167) at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.buildEnvVars(MavenExtractorEnvironment.java:100) at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:947) at hudson.maven.AbstractMavenBuild.getEnvironment(AbstractMavenBuild.java:56) at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:165) at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:620) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534) at hudson.model.Run.execute(Run.java:1738) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:529) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410)Caused by: java.lang.IllegalArgumentException: mavenHome '/home/srijini/maven/apache-maven-3.3.9' doesn't seem to exist on this node (or you don't have sufficient rights to access it) at hudson.maven.MavenEmbedderUtils.buildClassRealm(MavenEmbedderUtils.java:76) at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:188) at hudson.maven.MavenEmbedderUtils.isAtLeastMavenVersion(MavenEmbedderUtils.java:215) at org.jfrog.hudson.maven3.MavenVersionCallable.call(MavenVersionCallable.java:45) at org.jfrog.hudson.maven3.MavenVersionCallable.call(MavenVersionCallable.java:33) at hudson.FilePath.act(FilePath.java:1077) at org.jfrog.hudson.util.MavenVersionHelper.isAtLeast(MavenVersionHelper.java:109) at org.jfrog.hudson.util.MavenVersionHelper.isAtLeastVersion(MavenVersionHelper.java:81) at org.jfrog.hudson.util.MavenVersionHelper.isAtLeastResolutionCapableVersion(MavenVersionHelper.java:72) at org.jfrog.hudson.maven3.extractor.MavenExtractorEnvironment.isMavenVersionValid(MavenExtractorEnvironment.java:165) ... 10 more