org.openqa.selenium.NoSuchElementException

Unable to locate By.xpath: //*[@id='credentials-dialog-form']//*[@path='/'] in http://127.0.0.1:49680/computer/createItem For documentation on this error, please visit: http://seleniumhq.org/exceptions/no_such_element.html Build info: version: '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46' System info: host: 'ip-10-216-229-216', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.2.0-30-generic', java.version: '1.8.0_40' Driver info: driver.version: unknown

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web128

  • via Jenkins JIRA by Andrew Bayer, 11 months ago
    : '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46' System info: host: 'ip-10-216-229-216', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.2.0-30-generic', java.version: '1.8.0_40' Driver info: driver.version: unknown
  • via Jenkins JIRA by Andrew Bayer, 11 months ago
    : '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46' System info: host: 'ip-10-216-229-216', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.2.0-30-generic', java.version: '1.8.0_40' Driver info: driver.version: unknown
  • via Jenkins JIRA by Andrew Bayer, 11 months ago
    : '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46' System info: host: 'ip-10-216-229-216', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.2.0-30-generic', java.version: '1.8.0_40' Driver info: driver.version: unknown
  • Stack trace

    • org.openqa.selenium.NoSuchElementException: Unable to locate By.xpath: //*[@id='credentials-dialog-form']//*[@path='/'] in http://127.0.0.1:49680/computer/createItem For documentation on this error, please visit: http://seleniumhq.org/exceptions
    • o_such_element.html Build info: version: '2.53.0', revision: '35ae25b1534ae328c771e0856c93e187490ca824', time: '2016-03-15 10:43:46' System info: host: 'ip-10-216-229-216', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '4.2.0-30-generic', java.version: '1.8.0_40' Driver info: driver.version: unknown at org.openqa.selenium.support.ui.FluentWait.timeoutException(FluentWait.java:292) at org.jenkinsci.test.acceptance.junit.Wait.timeoutException(Wait.java:143) at org.openqa.selenium.support.ui.FluentWait.until(FluentWait.java:261) at org.jenkinsci.test.acceptance.junit.Wait.until(Wait.java:74) at org.jenkinsci.test.acceptance.po.CapybaraPortingLayerImpl.find(CapybaraPortingLayerImpl.java:177) at org.jenkinsci.test.acceptance.po.Control.resolve(Control.java:65) at org.jenkinsci.test.acceptance.po.Control.select(Control.java:222) at org.jenkinsci.test.acceptance.plugins.ssh_credentials.SshCredentialDialog$1.resolve(SshCredentialDialog.java:28) at org.jenkinsci.test.acceptance.po.CapybaraPortingLayerImpl$Resolver.find(CapybaraPortingLayerImpl.java:421) at org.jenkinsci.test.acceptance.po.CapybaraPortingLayerImpl.findCaption(CapybaraPortingLayerImpl.java:389) at org.jenkinsci.test.acceptance.plugins.ssh_credentials.SshCredentialDialog.select(SshCredentialDialog.java:25) at org.jenkinsci.test.acceptance.plugins.ssh_slaves.SshSlaveLauncher.pwdCredentials(SshSlaveLauncher.java:57) at plugins.SshSlavesPluginTest.unableToConnectWrongCredentials(SshSlavesPluginTest.java:85)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.