org.apache.maven.lifecycle.LifecycleExecutionException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • [JIRA] (JENKINS-36872) Unable to release jenkins on Java 8
    via by ogo...@gmail.com (JIRA),
  • Releasing LTS RC on "Java(TM) SE Runtime Environment (build 1.8.0_92-b14)" fails with: {noformat} [ERROR] Failed to execute goal org.codehaus.mojo:apt-maven-plugin:1.0-alpha-5:process (default) on project jenkins-core: Unable to locate the apt compiler in: [ERROR] /usr/lib/jvm/java-8-jdk/jre/../lib/tools.jar [ERROR] Please ensure you are using JDK 1.5 or above and [ERROR] not a JRE (the com.sun.tools.apt.Main class is required). [ERROR] In most cases you can change the location of your Java [ERROR] installation by setting the JAVA_HOME environment variable. [ERROR] -> [Help 1] org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:apt-maven-plugin:1.0-alpha-5:process (default) on project jenkins-core: Unable to locate the apt compiler in: /usr/lib/jvm/java-8-jdk/jre/../lib/tools.jar Please ensure you are using JDK 1.5 or above and not a JRE (the com.sun.tools.apt.Main class is required). In most cases you can change the location of your Java installation by setting the JAVA_HOME environment variable. at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288) at org.apache.maven.cli.MavenCli.main(MavenCli.java:199) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) Caused by: org.apache.maven.plugin.MojoExecutionException: Unable to locate the apt compiler in: /usr/lib/jvm/java-8-jdk/jre/../lib/tools.jar Please ensure you are using JDK 1.5 or above and not a JRE (the com.sun.tools.apt.Main class is required). In most cases you can change the location of your Java installation by setting the JAVA_HOME environment variable. at org.codehaus.mojo.apt.AptUtils.getAptClass(AptUtils.java:220) at org.codehaus.mojo.apt.AptUtils.invoke(AptUtils.java:76) at org.codehaus.mojo.apt.AbstractAptMojo.executeApt(AbstractAptMojo.java:389) at org.codehaus.mojo.apt.AbstractAptMojo.executeImpl(AbstractAptMojo.java:277) at org.codehaus.mojo.apt.AbstractAptMojo.execute(AbstractAptMojo.java:254) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207) ... 20 more {noformat}
    via by Oliver Gondža,
    • org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:apt-maven-plugin:1.0-alpha-5:process (default) on project jenkins-core: Unable to locate the apt compiler in: /usr/lib/jvm/java-8-jdk/jre/../lib/tools.jar Please ensure you are using JDK 1.5 or above and not a JRE (the com.sun.tools.apt.Main class is required). In most cases you can change the location of your Java installation by setting the JAVA_HOME environment variable. at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288) at org.apache.maven.cli.MavenCli.main(MavenCli.java:199) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) Caused by: org.apache.maven.plugin.MojoExecutionException: Unable to locate the apt compiler in: /usr/lib/jvm/java-8-jdk/jre/../lib/tools.jar Please ensure you are using JDK 1.5 or above and not a JRE (the com.sun.tools.apt.Main class is required). In most cases you can change the location of your Java installation by setting the JAVA_HOME environment variable. at org.codehaus.mojo.apt.AptUtils.getAptClass(AptUtils.java:220) at org.codehaus.mojo.apt.AptUtils.invoke(AptUtils.java:76) at org.codehaus.mojo.apt.AbstractAptMojo.executeApt(AbstractAptMojo.java:389) at org.codehaus.mojo.apt.AbstractAptMojo.executeImpl(AbstractAptMojo.java:277) at org.codehaus.mojo.apt.AbstractAptMojo.execute(AbstractAptMojo.java:254) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207) ... 20 more
    No Bugmate found.