org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Hi Greg, I am getting the below error when i try to deploy an EAR please help! Connecting to IBM WebSphere Application Server... The following artifacts will be deployed in this order... ------------------------------------------- xxxxxxxxxxx-SNAPSHOT.ear ------------------------------------------- Deploying 'xxxxxxxxxxx' to IBM WebSphere Application Server InstallApplication] ADMA5011I: The cleanup of the temp directory for application xxxxxxxxxxx is complete.[InProgress] InstallApplication] ADMA5014E: The installation of application xxxxxxxxxxx failed.[Failed] Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Application not successfully deployed: ADMA5011I: The cleanup of the temp directory for application xxxxxxxxxxx is complete. ADMA5014E: The installation of application xxxxxxxxxxx failed. at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:251) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE Finished: FAILURE
    via by sijo josan,
  • WebSphere 7 + WebSphere Deployer Plugin
    via Stack Overflow by Kestas KK
    ,
  • Hi, I can connect to remote WAS ND 8.x and run a deployment of EAR file but got the error Started by user Nhu Nguyen Building in workspace D:\Bitnami\jenkins-1.635-1\apps\jenkins\jenkins_home\jobs\Projects\jobs\BAMS eBAMS\jobs\Delivery\jobs\Deploy to UAT\workspace Unable to find a build for artifact copy from: Projects/BAMS eBAMS/Developer Jobs/Basic Maven Build Connecting to IBM WebSphere Application Server... The following artifacts will be deployed in this order... ------------------------------------------- bo-business-ear-4.7.0.1.ear ------------------------------------------- Deploying 'bo-business-ear-4.7.0.1' to IBM WebSphere Application Server Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Failure uploading archive to server at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:251) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671) at hudson.model.Run.execute(Run.java:1766) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE Notifying upstream projects of job completion Finished: FAILURE I checked also the output from Jenkins server and found Nov 09, 2015 2:18:54 PM hudson.model.Run execute INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #22 main build action completed: SUCCESS Nov 09, 2015 2:18:54 PM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props Nov 09, 2015 2:19:11 PM hudson.model.Run execute INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #23 main build action completed: SUCCESS Nov 09, 2015 2:19:11 PM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props Nov 09, 2015 2:19:38 PM hudson.model.Run execute INFO: Projects/BAMS eBAMS/Delivery/Deploy to UAT #24 main build action completed: SUCCESS Nov 09, 2015 2:19:38 PM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props Nov 09, 2015 2:19:56 PM com.ibm.ws.management.filetransfer.client.FileTransferClientImpl AUDIT: ADFS0109E: FileTransferClient failed to get server configuration information: java.security.PrivilegedActionException: javax.management.RuntimeOperationsException: The "name" parameter cannot be null. at com.ibm.ws.security.auth.ContextManagerImpl.runAsSystem(ContextManagerImpl.java:5608) at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl.sendGetServerConfigRequest(FileTransferClientImpl.java:2539) at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl.initialize(FileTransferClientImpl.java:2389) at com.ibm.ws.management.fileservice.FileTransferFactory.getFileTransferClient(FileTransferFactory.java:166) at com.ibm.ws.management.application.client.AppInstallHelper.copyToServer(AppInstallHelper.java:1240) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at com.ibm.websphere.management.application.AppManagementProxy.uploadArchive(AppManagementProxy.java:718) at com.ibm.websphere.management.application.AppManagementProxy.installApplication(AppManagementProxy.java:507) at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:237) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671) at hudson.model.Run.execute(Run.java:1766) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) Caused by: javax.management.RuntimeOperationsException: The "name" parameter cannot be null. at com.ibm.ws.management.AdminClientImpl.assertObjectNameValid(AdminClientImpl.java:340) at com.ibm.ws.management.AdminClientImpl.invoke(AdminClientImpl.java:209) at com.ibm.ws.management.filetransfer.client.FileTransferClientImpl$1.run(FileTransferClientImpl.java:2536) at com.ibm.ws.security.auth.ContextManagerImpl.runAsSystem(ContextManagerImpl.java:5599) ... 22 more Caused by: java.lang.IllegalArgumentException: The "name" parameter cannot be null. ... 26 more Cuold you please help to check this issue? Thanks,
    via by Nhu Nguyen,
  • When deploying an artifact to Websphere. The application is successfully stopped, but once the artifact tries to upload, the below error occurs: Stopping Old Application 'XX'... Updating 'XX' on IBM WebSphere Application Server Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to updated artifact: Failure uploading archive to server at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:278) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721) at hudson.model.Build$BuildExecution.post2(Build.java:183) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670) at hudson.model.Run.execute(Run.java:1766) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:374) As an FYI - i tried using plugin version 1..3.4 and the beta 1.4. Our websphere keystore and truststore are stored as .p12 files. I tried using the .p12 files directly and also created a JKS file and converted them from pkcs12 to JKS format.
    via by Rusty Bentz,
  • When attempting to deploy an ear the build process just hangs. Nothing is seen in the logs on either jenkins or websphere. If there is an existing deployment, that gets undeployed but the ear is not deployed. I have set the timeout property to 5 minutes but that does not seem to have any effect, the build will keep going. When I cancel the build, the following exception is seen: {code:java} Deploying 'XpressEar' to IBM WebSphere Application Server Deploying to targets: WebSphere:cell=Dci8FBDev,node=dci8-fbdev-n1,server=Xpress1 Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: null at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:284) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:216) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:193) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:756) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720) at hudson.model.Build$BuildExecution.post2(Build.java:182) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:669) at hudson.model.Run.execute(Run.java:1731) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:232) {code}
    via by Mark Stamp,
  • The WebSphere Deployer plugin is able to connect to the remote WAS 8.5.5.5 server, and stop/remove/install a WAR/EAR. I can see the new app shows up on the WAS console as stopped, and the following line in the SystemOut.log ADMA5013I: Application HelloWorldServlet installed successfully. But the build just hung there forever, not able to start the app, and no error in the remote server log, only found the following error in the Jenkins log until I cancel the build: Nov 13, 2015 8:11:36 AM hudson.model.Run execute INFO: Test Project #26 main build action completed: SUCCESS Nov 13, 2015 8:11:36 AM com.ibm.websphere.management.AdminClientFactory WARNING: ADMC0046W: The system failed to load properties from com.ibm.SOAP.configURL: file:null/properties/soap.client.props java.lang.InterruptedException at java.lang.Object.wait(Native Method) at java.lang.Object.wait(Unknown Source) at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:270) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to updated artifact: null at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.updateArtifact(WebSphereDeploymentService.java:278) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.updateArtifact(WebSphereDeployerPlugin.java:252) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:206) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410) thanks. java9394
    via by Java Guy,
    • org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Application not successfully deployed: ADMA5011I: The cleanup of the temp directory for application xxxxxxxxxxx is complete. ADMA5014E: The installation of application xxxxxxxxxxx failed. at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:251) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:227) at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:201) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723) at hudson.model.Build$BuildExecution.post2(Build.java:185) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668) at hudson.model.Run.execute(Run.java:1763) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:98) at hudson.model.Executor.run(Executor.java:410)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,