java.lang.NullPointerException

Jenkins JIRA | sgybas | 7 years ago
  1. 0
  2. 0
  3. 0

    hi! i'm trying to deploy artifacts to artifactory and i followed the tutorial, however, i got the same problem no matter what: Waiting for Jenkins to finish collecting data channel stopped Deploying artifacts to http://192.168.1.22/artifactory Deploying artifacts of module: etask.components.security:COM-SecurityGuardEntities ERROR: null java.lang.NullPointerException at org.jfrog.hudson.util.BuildUniqueIdentifierHelper.getUpstreamIdentifier(BuildUniqueIdentifierHelper.java:106) at org.jfrog.hudson.maven2.ArtifactsDeployer.deployArtifact(ArtifactsDeployer.java:170) at org.jfrog.hudson.maven2.ArtifactsDeployer.deploy(ArtifactsDeployer.java:127) at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:300) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685) at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:994) at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632) at hudson.model.Run.run(Run.java:1463) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:239) Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE Finished: FAILURE it doesn't say anything i can use to resolve the problem. i attached the configuration of jenkins thank you so much for the help, Maritzabell Suarez

    Jenkins JIRA | 5 years ago | maritzabell suarez
    java.lang.NullPointerException
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.NullPointerException

      No message provided

      at org.jfrog.hudson.ArtifactsDeployer.deploy()
    2. org.jfrog.hudson
      ArtifactoryRedeployPublisher.perform
      1. org.jfrog.hudson.ArtifactsDeployer.deploy(ArtifactsDeployer.java:62)
      2. org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:99)
      2 frames
    3. Hudson
      AbstractBuild$AbstractRunner.performAllBuildStep
      1. hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      2. hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:582)
      3. hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:563)
      3 frames
    4. Hudson Maven Embedder
      MavenModuleSetBuild$RunnerImpl.post2
      1. hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:594)
      1 frame
    5. Hudson
      Run.run
      1. hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
      2. hudson.model.Run.run(Run.java:1221)
      2 frames
    6. Hudson Maven Embedder
      MavenModuleSetBuild.run
      1. hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304)
      1 frame
    7. Hudson
      Executor.run
      1. hudson.model.ResourceController.execute(ResourceController.java:88)
      2. hudson.model.Executor.run(Executor.java:122)
      2 frames