java.io.IOException

tip

Check if you didn't set RequestProperty Content-Type to the wrong type or if you're trying to send the wrong file to the server.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • When I´m trying to enable the ACS for my app. Titanium Studio shows me the following error: Failed to register app for ACS. Please retry later. If this re-occurs, please check your logfile and report a bug. Reason: Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json My account works fine logging at appcelerator.com and I have 2 apps working with ACS. Thank you for your support. This is de GUID of my app: 77263cc0-d70b-4fd9-846d-4e68058a963b I tried to register other apps at new creation and after creation and shows the same crash. So, this is the content of my logfile: !ENTRY com.appcelerator.titanium.ui.ide 4 0 2015-03-03 11:05:11.060 !MESSAGE (Build 3.4.1.201410281727) [ERROR] Failed to register app for ACS !STACK 0 java.io.IOException: Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1459) at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234) at com.appcelerator.titanium.core.internal.acs.ACSManager.login(ACSManager.java:112) at com.appcelerator.titanium.ui.ide.tiappEditor.TiAppCloudSectionContributor$1$1.run(TiAppCloudSectionContributor.java:271) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    via by Fran Rodas,
  • When I´m trying to enable the ACS for my app. Titanium Studio shows me the following error: Failed to register app for ACS. Please retry later. If this re-occurs, please check your logfile and report a bug. Reason: Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json My account works fine logging at appcelerator.com and I have 2 apps working with ACS. Thank you for your support. This is de GUID of my app: 77263cc0-d70b-4fd9-846d-4e68058a963b I tried to register other apps at new creation and after creation and shows the same crash. So, this is the content of my logfile: !ENTRY com.appcelerator.titanium.ui.ide 4 0 2015-03-03 11:05:11.060 !MESSAGE (Build 3.4.1.201410281727) [ERROR] Failed to register app for ACS !STACK 0 java.io.IOException: Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1459) at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234) at com.appcelerator.titanium.core.internal.acs.ACSManager.login(ACSManager.java:112) at com.appcelerator.titanium.ui.ide.tiappEditor.TiAppCloudSectionContributor$1$1.run(TiAppCloudSectionContributor.java:271) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    via by Fran Rodas,
  • iOS Mobile Automation using Appium | Smriti Tuteja
    via by Unknown author,
  • error while calling a soap webservice in eclipse
    via by Unknown author,
  • twitty - File Exchange - MATLAB Central
    via by Unknown author,
  • Reading from an https-URL in java
    via Stack Overflow by njcasdewdwas
    ,
  • [mcMMO] Unable to fetch UUIDs!
    via GitHub by d1One
    ,
    • java.io.IOException: Server returned HTTP response code: 400 for URL: https://api.cloud.appcelerator.com/v1/admins/studio_login.json at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1459) at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234) at com.appcelerator.titanium.core.internal.acs.ACSManager.login(ACSManager.java:112) at com.appcelerator.titanium.ui.ide.tiappEditor.TiAppCloudSectionContributor$1$1.run(TiAppCloudSectionContributor.java:271) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    tfr
    35 times, last one,
    davidvanlaatum
    1 times, last one,
    Unknown visitor1 times, last one,
    69 more bugmates