java.lang.NoClassDefFoundError: hudson/Main (wrong name: Main)

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Solutions on the web

via Jenkins JIRA by ajuffinger, 1 year ago
hudson/Main (wrong name: Main)
via Jenkins JIRA by ajuffinger, 1 year ago
hudson/Main (wrong name: Main)
via java-forums.org by Unknown author, 1 year ago
Main (wrong name: classsched/Main)
via Stack Overflow by Dragos
, 1 year ago
MyClass(wrong name: com/example/main/MyClass)
via askjonskeet.com by Unknown author, 1 year ago
MyClass(wrong name: com/example/main/MyClass)
via Coderanch by Keitaro Oman, 1 year ago
Simpledotcomtestdrive (wrong name: SimpleDotComTestDrive)
java.lang.NoClassDefFoundError: hudson/Main (wrong name: Main)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1302)
at hudson.EnvVars.initMaster(EnvVars.java:223)
at hudson.EnvVars.(EnvVars.java:218)
at hudson.model.Computer.getEnvironment(Computer.java:736)
at hudson.model.Run.getEnvironment(Run.java:1648)
at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:663)
at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:128)
at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:384)
at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
at hudson.model.Run.run(Run.java:1243)
at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304)
at hudson.model.ResourceController.execute(ResourceController.java:88)
at hudson.model.Executor.run(Executor.java:122)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Once, 4 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.