java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Gerrit Trigger - Jenkins - Jenkins Wiki
    via by Unknown author,
  • Git plugin fails with NPE after upgrade to Jenkins 1.502 / Git Plugin 1.2.0. This could not be solved by upgrading to 1.503. {code} Started by user **** Building remotely on **** in workspace **** Checkout:**** / **** - hudson.remoting.Channel@d5ba3a:**** Using strategy: Default FATAL: null java.lang.NullPointerException at hudson.plugins.git.GitSCM.getGitExe(GitSCM.java:839) at hudson.plugins.git.GitSCM.getGitExe(GitSCM.java:829) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1100) at hudson.model.AbstractProject.checkout(AbstractProject.java:1342) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:683) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:588) at hudson.model.Run.execute(Run.java:1567) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:237) {code} I tried with older versions of git plugin: ||Git Plugin version||Cause||Code|| |1.2.0|NPE|GitSCM.java:839| |1.1.29|IllegalAccessError|GitSCM.java:940| |1.1.27|ClassCastException|GitSCM.java:1370| |1.1.26|NPE|GitSCM.java:875| |1.1.25|NPE|GitSCM.java:867| |1.1.24|NPE|GitSCM.java:871| |1.1.23|NPE|GitSCM.java:993| |1.1.22|NPE|GitSCM.java:935| https://github.com/jenkinsci/git-plugin/blob/git-1.2.0/src/main/java/hudson/plugins/git/GitSCM.java#L839 I'm not yet tried to attach any debugger, but it looks like Jenkins returns no git tool installations to the plugin. Configuration seems correct, at least same setting worked with previous Jenkins 1.498 / git plugin 1.1.25. {code} <?xml version='1.0' encoding='UTF-8'?> <hudson.plugins.git.GitTool_-DescriptorImpl plugin="git-client@1.0.3"> <installations class="hudson.plugins.git.GitTool-array"> <hudson.plugins.git.GitTool> <name>Default</name> <home>/usr/bin/git</home> </hudson.plugins.git.GitTool> </installations> </hudson.plugins.git.GitTool_-DescriptorImpl> {code}
    via by Takayuki Okazaki,
  • Git plugin fails with NPE after upgrade to Jenkins 1.502 / Git Plugin 1.2.0. This could not be solved by upgrading to 1.503. {code} Started by user **** Building remotely on **** in workspace **** Checkout:**** / **** - hudson.remoting.Channel@d5ba3a:**** Using strategy: Default FATAL: null java.lang.NullPointerException at hudson.plugins.git.GitSCM.getGitExe(GitSCM.java:839) at hudson.plugins.git.GitSCM.getGitExe(GitSCM.java:829) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1100) at hudson.model.AbstractProject.checkout(AbstractProject.java:1342) at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:683) at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:588) at hudson.model.Run.execute(Run.java:1567) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:237) {code} I tried with older versions of git plugin: ||Git Plugin version||Cause||Code|| |1.2.0|NPE|GitSCM.java:839| |1.1.29|IllegalAccessError|GitSCM.java:940| |1.1.27|ClassCastException|GitSCM.java:1370| |1.1.26|NPE|GitSCM.java:875| |1.1.25|NPE|GitSCM.java:867| |1.1.24|NPE|GitSCM.java:871| |1.1.23|NPE|GitSCM.java:993| |1.1.22|NPE|GitSCM.java:935| https://github.com/jenkinsci/git-plugin/blob/git-1.2.0/src/main/java/hudson/plugins/git/GitSCM.java#L839 I'm not yet tried to attach any debugger, but it looks like Jenkins returns no git tool installations to the plugin. Configuration seems correct, at least same setting worked with previous Jenkins 1.498 / git plugin 1.1.25. {code} <?xml version='1.0' encoding='UTF-8'?> <hudson.plugins.git.GitTool_-DescriptorImpl plugin="git-client@1.0.3"> <installations class="hudson.plugins.git.GitTool-array"> <hudson.plugins.git.GitTool> <name>Default</name> <home>/usr/bin/git</home> </hudson.plugins.git.GitTool> </installations> </hudson.plugins.git.GitTool_-DescriptorImpl> {code}
    via by Takayuki Okazaki,
    • java.lang.NullPointerException at hudson.plugins.git.GitSCM.getGitConfigNameToUse(GitSCM.java:320) at hudson.plugins.git.GitSCM.checkout(GitSCM.java:787) at hudson.model.AbstractProject.checkout(AbstractProject.java:1181) at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:536) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:424) at hudson.model.Run.run(Run.java:1374) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88)
    No Bugmate found.