java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I'm trying to configure the Perforce plugin (1.1.9) with Hudson (1.378), and Build Now fails every time with this log (same when the job polls): Started by user anonymous Clearing workspace... Cleared workspace. Using master perforce client: hudson [workspace] $ /Users/abrockett/perforce/p4 workspace -o hudson Changing P4 Client Root to: /Users/abrockett/.hudson/jobs/p4test/workspace FATAL: null java.lang.NullPointerException at hudson.plugins.perforce.PerforceSCM.parseProjectPath(PerforceSCM.java:1386) at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:1028) at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:504) at hudson.model.AbstractProject.checkout(AbstractProject.java:1082) at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:479) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:411) at hudson.model.Run.run(Run.java:1280) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:137) when the job runs. I created a new p4 user, as suggested, and a new workspace (named hudson) for Hudson to use. Let Hudson Manage Workspace View is checked, along with one time force sync and always force sync. The plugin appears to have no trouble executing p4 commands. P4PORT is set to localhost:1666, username and password are correct for the hudson user. Searching the issues here and the comments on the wiki at http://wiki.jenkins-ci.org/display/JENKINS/Perforce+Plugin don't turn up anybody with similar problems, so I suspect it's some simple setup problem. I'd be grateful for a shove in the right direction.
    via by atbrockett,
  • I'm trying to configure the Perforce plugin (1.1.9) with Hudson (1.378), and Build Now fails every time with this log (same when the job polls): Started by user anonymous Clearing workspace... Cleared workspace. Using master perforce client: hudson [workspace] $ /Users/abrockett/perforce/p4 workspace -o hudson Changing P4 Client Root to: /Users/abrockett/.hudson/jobs/p4test/workspace FATAL: null java.lang.NullPointerException at hudson.plugins.perforce.PerforceSCM.parseProjectPath(PerforceSCM.java:1386) at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:1028) at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:504) at hudson.model.AbstractProject.checkout(AbstractProject.java:1082) at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:479) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:411) at hudson.model.Run.run(Run.java:1280) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:137) when the job runs. I created a new p4 user, as suggested, and a new workspace (named hudson) for Hudson to use. Let Hudson Manage Workspace View is checked, along with one time force sync and always force sync. The plugin appears to have no trouble executing p4 commands. P4PORT is set to localhost:1666, username and password are correct for the hudson user. Searching the issues here and the comments on the wiki at http://wiki.jenkins-ci.org/display/JENKINS/Perforce+Plugin don't turn up anybody with similar problems, so I suspect it's some simple setup problem. I'd be grateful for a shove in the right direction.
    via by atbrockett,
    • java.lang.NullPointerException at hudson.plugins.perforce.PerforceSCM.parseProjectPath(PerforceSCM.java:1386) at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:1028) at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:504) at hudson.model.AbstractProject.checkout(AbstractProject.java:1082) at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:479) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:411) at hudson.model.Run.run(Run.java:1280) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:137)
    No Bugmate found.