java.lang.ClassCastException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • JIRA 4.0 does not run on WebLogic 10, even with the fixes for JRA-19367 it does not work. When you enable the {{<prefer-web-inf-classes>true</prefer-web-inf-classes>}} option you end up with some ClassCastException when trying to deploy the application: {code} java.lang.ClassCastException: com.ctc.wstx.stax.WstxInputFactory at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:137) at weblogic.servlet.internal.TldCacheHelper$TldIOHelper.parseXML(TldCacheHelper.java:124) at weblogic.descriptor.DescriptorCache.parseXML(DescriptorCache.java:380) at weblogic.servlet.internal.TldCacheHelper.parseTagLibraries(TldCacheHelper.java:65) at weblogic.servlet.internal.War.getTagInfo(War.java:891) at weblogic.servlet.internal.WebAppServletContext$ServletContextWebAppHelper.getTldInfo(WebAppServletContext.java:3612) {code} I guess WebLogic is using some parser from within JIRA or its plugins and is thus having some problems. If you try {{<prefer-web-inf-classes>false</prefer-web-inf-classes>}} this you get the following error when booting up JIRA. {code} java.lang.NoSuchMethodError: join at com.atlassian.plugin.osgi.factory.transform.stage.GenerateManifestStage.execute(GenerateManifestStage.java:124) at com.atlassian.plugin.osgi.factory.transform.DefaultPluginTransformer.transform(DefaultPluginTransformer.java:113) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.createOsgiPluginJar(OsgiPluginFactory.java:218) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:152) at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:115) at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:88) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:135) at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:49) at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:1275) at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:226) at com.atlassian.jira.ComponentManager.start(ComponentManager.java:210) {code} This is caused by accessing an old versions of commons-lang from some where. The full log is attached for other information. The actual problems start happening at 12/10/2009 03:44:59 PM EST. The other errors are just setup problems. I have the install in a VM if you want to have a play.
    via by Brenden Bain [Atlassian],
  • JIRA 4.0 does not run on WebLogic 10, even with the fixes for JRA-19367 it does not work. When you enable the {{<prefer-web-inf-classes>true</prefer-web-inf-classes>}} option you end up with some ClassCastException when trying to deploy the application: {code} java.lang.ClassCastException: com.ctc.wstx.stax.WstxInputFactory at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:137) at weblogic.servlet.internal.TldCacheHelper$TldIOHelper.parseXML(TldCacheHelper.java:124) at weblogic.descriptor.DescriptorCache.parseXML(DescriptorCache.java:380) at weblogic.servlet.internal.TldCacheHelper.parseTagLibraries(TldCacheHelper.java:65) at weblogic.servlet.internal.War.getTagInfo(War.java:891) at weblogic.servlet.internal.WebAppServletContext$ServletContextWebAppHelper.getTldInfo(WebAppServletContext.java:3612) {code} I guess WebLogic is using some parser from within JIRA or its plugins and is thus having some problems. If you try {{<prefer-web-inf-classes>false</prefer-web-inf-classes>}} this you get the following error when booting up JIRA. {code} java.lang.NoSuchMethodError: join at com.atlassian.plugin.osgi.factory.transform.stage.GenerateManifestStage.execute(GenerateManifestStage.java:124) at com.atlassian.plugin.osgi.factory.transform.DefaultPluginTransformer.transform(DefaultPluginTransformer.java:113) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.createOsgiPluginJar(OsgiPluginFactory.java:218) at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:152) at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:115) at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:88) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:135) at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:49) at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:1275) at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:226) at com.atlassian.jira.ComponentManager.start(ComponentManager.java:210) {code} This is caused by accessing an old versions of commons-lang from some where. The full log is attached for other information. The actual problems start happening at 12/10/2009 03:44:59 PM EST. The other errors are just setup problems. I have the install in a VM if you want to have a play.
    via by Brenden Bain [Atlassian],
  • db:: 3.25::Problems with app descriptor.xml fp
    via by Unknown author,
    • java.lang.ClassCastException: com.ctc.wstx.stax.WstxInputFactory at javax.xml.stream.XMLInputFactory.newInstance(XMLInputFactory.java:137) at weblogic.servlet.internal.TldCacheHelper$TldIOHelper.parseXML(TldCacheHelper.java:124) at weblogic.descriptor.DescriptorCache.parseXML(DescriptorCache.java:380) at weblogic.servlet.internal.TldCacheHelper.parseTagLibraries(TldCacheHelper.java:65) at weblogic.servlet.internal.War.getTagInfo(War.java:891) at weblogic.servlet.internal.WebAppServletContext$ServletContextWebAppHelper.getTldInfo(WebAppServletContext.java:3612)

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    1 more bugmates