Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

  1. ,
    via Google Groups by Marcus Haebler

    Update "latest" to Java 8 on DockerHub.

  2. ,
    via Stack Overflow by ERJAN

    This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Solutions on the web

via GitHub by Couby
, 1 year ago
java.lang.UnsupportedClassVersionError: com/radiofreederp/nodebbintegration/NodeBBIntegrationBukkit : Unsupported major.minor version 52.0
via GitHub by JumanjiCraft
, 1 year ago
java.lang.UnsupportedClassVersionError: com/Ben12345rocks/VotingPlugin/Main : Unsupported major.minor version 52.0
via GitHub by NewgroundGaming
, 2 years ago
java.lang.UnsupportedClassVersionError: com/github/joelgodofwar/sps/PluginBase : Unsupported major.minor version 52.0
via GitHub by The-Unnamed-Engineer
, 1 year ago
java.lang.UnsupportedClassVersionError: com/github/joelgodofwar/sps/PluginBase : Unsupported major.minor version 52.0
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/radiofreederp/nodebbintegration/NodeBBIntegrationBukkit : Unsupported major.minor version 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:294)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.craftbukkit.v1_10_R1.CraftServer.<init>(CraftServer.java:256)[bukkit.jar:git-Bukkit-6053c5c] at net.minecraft.server.v1_10_R1.PlayerList.<init>(PlayerList.java:70)[bukkit.jar:git-Bukkit-6053c5c] at net.minecraft.server.v1_10_R1.DedicatedPlayerList.<init>(SourceFile:14)[bukkit.jar:git-Bukkit-6053c5c] at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:184)[bukkit.jar:git-Bukkit-6053c5c] at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:514)[bukkit.jar:git-Bukkit-6053c5c] at java.lang.Thread.run(Thread.java:745)[?:1.7.0_101]Caused by: java.lang.UnsupportedClassVersionError: com/radiofreederp/nodebbintegration/NodeBBIntegrationBukkit : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method)[?:1.7.0_101] at java.lang.ClassLoader.defineClass(ClassLoader.java:803)[?:1.7.0_101] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)[?:1.7.0_101] at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)[?:1.7.0_101] at java.net.URLClassLoader.access$100(URLClassLoader.java:71)[?:1.7.0_101] at java.net.URLClassLoader$1.run(URLClassLoader.java:361)[?:1.7.0_101] at java.net.URLClassLoader$1.run(URLClassLoader.java:355)[?:1.7.0_101] at java.security.AccessController.doPrivileged(Native Method)[?:1.7.0_101] at java.net.URLClassLoader.findClass(URLClassLoader.java:354)[?:1.7.0_101] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:77)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62)[bukkit.jar:git-Bukkit-6053c5c] at java.lang.ClassLoader.loadClass(ClassLoader.java:425)[?:1.7.0_101] at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[?:1.7.0_101] at java.lang.Class.forName0(Native Method)[?:1.7.0_101] at java.lang.Class.forName(Class.java:278)[?:1.7.0_101] at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:40)[bukkit.jar:git-Bukkit-6053c5c] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129)[bukkit.jar:git-Bukkit-6053c5c] ... 9 more