com.atlassian.plugin.osgi.container.OsgiContainerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Seems to have been introduced by https://atlaseye.atlassian.com/browse/bamboo/trunk/pom.xml?r=150796 {noformat} 2011-05-04 13:59:22,172 INFO [Spring executor 3] [OsgiPlugin] Waiting for service '&delegateTokenStore' for plugin 'com.atlassian.oauth.serviceprovider' with filter (objectClass=com.atlassian.oauth.serviceprovider.ServiceProviderTokenStore) 2011-05-04 13:59:22,424 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.applinks.applinks-plugin' : Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-05-04 13:59:22,425 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.applinks.applinks-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.applinks.applinks-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:409) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:90) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:694) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:170) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:381) ... 20 more 2011-05-04 13:59:22,426 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.applinks.applinks-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.applinks.applinks-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:409) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:90) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:694) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:170) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:381) ... 20 more 2011-05-04 13:59:22,454 INFO [Spring executor 1] [OsgiPlugin] Waiting for service '&templateContextFactory' for plugin 'com.atlassian.templaterenderer.atlassian-template-renderer-velocity1.6-plugin' with filter (objectClass=com.atlassian.templaterenderer.TemplateContextFactory) {noformat}
    via by James Dumay [Atlassian],
  • Seems to have been introduced by https://atlaseye.atlassian.com/browse/bamboo/trunk/pom.xml?r=150796 {noformat} 2011-05-04 13:59:22,172 INFO [Spring executor 3] [OsgiPlugin] Waiting for service '&delegateTokenStore' for plugin 'com.atlassian.oauth.serviceprovider' with filter (objectClass=com.atlassian.oauth.serviceprovider.ServiceProviderTokenStore) 2011-05-04 13:59:22,424 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.applinks.applinks-plugin' : Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)). This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-05-04 13:59:22,425 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.applinks.applinks-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.applinks.applinks-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:409) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:90) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:694) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:170) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:381) ... 20 more 2011-05-04 13:59:22,426 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.applinks.applinks-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.applinks.applinks-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:409) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:90) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:694) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:170) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:381) ... 20 more 2011-05-04 13:59:22,454 INFO [Spring executor 1] [OsgiPlugin] Waiting for service '&templateContextFactory' for plugin 'com.atlassian.templaterenderer.atlassian-template-renderer-velocity1.6-plugin' with filter (objectClass=com.atlassian.templaterenderer.TemplateContextFactory) {noformat}
    via by James Dumay [Atlassian],
  • After upgrading to the latest bamboo version (3.2), bamboo fails to start if one is using your plugin. Following exceptions do occur: 2011-07-28 12:06:24,902 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-07-28 12:06:24,903 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more 2011-07-28 12:06:24,903 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more
    via by Joerg Stephan,
  • The Bamboo-Artifactory depends on {{jackson-core-asl}} and {{jackson-mapper-asl}} version 1.5.1 and contains their extracted content. Installing the plugin in Bamboo 3.2.2 crashes the UPM on startup with the following error: {noformat} 2011-08-12 16:23:34,561 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-08-12 16:23:34,561 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more 2011-08-12 16:23:34,562 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more {noformat} Renaming the Bamboo-Artifactory plugin from {{bamboo-artifactory-plugin-1.4.1.jar}} to {{bamboo-artifactory-plugin.jar}} solves the issue. The plugin is of type 1 and doesn't utilize OSGi, but it seems as though the version in the file name somehow affects its interaction with the UPM.
    via by Noam Y. Tenne,
  • After upgrading to the latest bamboo version (3.2), bamboo fails to start if one is using your plugin. Following exceptions do occur: 2011-07-28 12:06:24,902 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-07-28 12:06:24,903 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more 2011-07-28 12:06:24,903 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more
    via by Joerg Stephan,
  • The Bamboo-Artifactory depends on {{jackson-core-asl}} and {{jackson-mapper-asl}} version 1.5.1 and contains their extracted content. Installing the plugin in Bamboo 3.2.2 crashes the UPM on startup with the following error: {noformat} 2011-08-12 16:23:34,561 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D 2011-08-12 16:23:34,561 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more 2011-08-12 16:23:34,562 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402) ... 20 more {noformat} Renaming the Bamboo-Artifactory plugin from {{bamboo-artifactory-plugin-1.4.1.jar}} to {{bamboo-artifactory-plugin.jar}} solves the issue. The plugin is of type 1 and doesn't utilize OSGi, but it seems as though the version in the file name somehow affects its interaction with the UPM.
    via by Noam Y. Tenne,
  • GitHub comment 16#8194551
    via GitHub by onepremise
    ,
  • Plugin Loading Errors Starting JIRA | Elemecca
    via by Unknown author,
    • com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.applinks.applinks-plugin at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:409) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:90) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:694) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:170) at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173) at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137) at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176) at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92) at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39) at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633) at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228) at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160) at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576) at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93) at org.eclipse.jetty.server.Server.doStart(Server.java:243) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55) at com.atlassian.bamboo.server.Server.main(Server.java:77) Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.applinks.plugin [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.sal.api)(version>=2.5.0)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:381) ... 20 more

    Users with the same issue

    davidvanlaatum
    28 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    14 more bugmates