org.springframework.beans.factory.CannotLoadBeanClassException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • JIRA fails initialization of the Greenhopper plugin during startup with the following exception. {code} 2010-10-04 14:41:23,738 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.oauth.serviceprovider, com.atlassian.sal.jira, com.atlassian.gadgets.publisher, com.atlassian.templaterenderer.api], 57 seconds remaining 2010-10-04 14:41:24,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 56 seconds remaining 2010-10-04 14:41:25,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 55 seconds remaining 2010-10-04 14:41:26,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 54 seconds remaining 2010-10-04 14:41:28,378 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 52 seconds remaining 2010-10-04 14:41:29,565 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 51 seconds remaining 2010-10-04 14:41:30,768 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 50 seconds remaining 2010-10-04 14:41:31,768 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 49 seconds remaining 2010-10-04 14:41:32,783 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 48 seconds remaining 2010-10-04 14:41:33,955 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 47 seconds remaining 2010-10-04 14:41:41,422 server.startup : 0 INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: d:\jira\plugins\installed-plugins\jira-greenhopper-plugin-5.3-beta3.jar (1285940614780) created 2010-10-04 14:41:43,109 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.pyxis.greenhopper.jira], 60 seconds remaining 2010-10-04 14:41:44,109 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.pyxis.greenhopper.jira], 59 seconds remaining 2010-10-04 14:41:44,359 Spring executor 12 ERROR [plugin.osgi.factory.OsgiPlugin] Unable to start the Spring context for plugin com.pyxis.greenhopper.jira org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.plugin.link.DefaultLinkProviderManager] for bean with name 'gh-linkProviderManager' defined in URL [bundle://42.0:1/com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1144) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:758) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:422) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355) at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:320) at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:132) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:678) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:703) at java.lang.Thread.run(Thread.java:811) Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:258) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1543) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:887) at org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99) at org.springframework.osgi.util.BundleDelegatingClassLoader.loadClass(BundleDelegatingClassLoader.java:156) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.springframework.util.ClassUtils.forName(ClassUtils.java:211) at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385) at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138) ... 13 more 2010-10-04 14:41:44,359 Spring executor 12 ERROR [extender.internal.activator.ContextLoaderListener] Application context refresh failed (NonValidatingOsgiBundleXmlApplicationContext(bundle=com.pyxis.greenhopper.jira, config=osgibundle:/META-INF/spring/*.xml)) org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.plugin.link.DefaultLinkProviderManager] for bean with name 'gh-linkProviderManager' defined in URL [bundle://42.0:1/com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1144) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:758) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:422) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355) at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:320) at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:132) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:678) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:703) at java.lang.Thread.run(Thread.java:811) Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:258) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1543) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:887) at org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99) at org.springframework.osgi.util.BundleDelegatingClassLoader.loadClass(BundleDelegatingClassLoader.java:156) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.springframework.util.ClassUtils.forName(ClassUtils.java:211) at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385) at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138) ... 13 more 2010-10-04 14:41:45,109 server.startup : 0 INFO [atlassian.plugin.manager.DefaultPluginManager] Plugin system started in 0:01:25.656 2010-10-04 14:41:45,890 server.startup : 0 INFO [atlassian.jira.startup.JiraStartupLogger] ___ Plugin System Started _________________ {code} The plugin is placed in the JIRA_HOME\plugins\installed-plugins directory, and the directory is added to the JVMs class path. JIRA is working, while the Greenhopper plugin is disabled. When I try enabling the plugin from the administration UI, I get the following message. {code} GreenHopper Description: Rich Management Client for JIRA (Build: #128546) Vendor: Atlassian Plugin Version: 5.3-beta3 JIRA Version: 4.2 Installation Mode: Managed There were errors loading this plugin: There was a problem loading the module descriptor: java.lang.Void.<br/>Unable to enable web fragment {code}
    via by Kris-Mikael Krister,
  • JIRA fails initialization of the Greenhopper plugin during startup with the following exception. {code} 2010-10-04 14:41:23,738 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.oauth.serviceprovider, com.atlassian.sal.jira, com.atlassian.gadgets.publisher, com.atlassian.templaterenderer.api], 57 seconds remaining 2010-10-04 14:41:24,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 56 seconds remaining 2010-10-04 14:41:25,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 55 seconds remaining 2010-10-04 14:41:26,769 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 54 seconds remaining 2010-10-04 14:41:28,378 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 52 seconds remaining 2010-10-04 14:41:29,565 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 51 seconds remaining 2010-10-04 14:41:30,768 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 50 seconds remaining 2010-10-04 14:41:31,768 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 49 seconds remaining 2010-10-04 14:41:32,783 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 48 seconds remaining 2010-10-04 14:41:33,955 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.gadgets.publisher], 47 seconds remaining 2010-10-04 14:41:41,422 server.startup : 0 INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: d:\jira\plugins\installed-plugins\jira-greenhopper-plugin-5.3-beta3.jar (1285940614780) created 2010-10-04 14:41:43,109 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.pyxis.greenhopper.jira], 60 seconds remaining 2010-10-04 14:41:44,109 server.startup : 0 INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.pyxis.greenhopper.jira], 59 seconds remaining 2010-10-04 14:41:44,359 Spring executor 12 ERROR [plugin.osgi.factory.OsgiPlugin] Unable to start the Spring context for plugin com.pyxis.greenhopper.jira org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.plugin.link.DefaultLinkProviderManager] for bean with name 'gh-linkProviderManager' defined in URL [bundle://42.0:1/com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1144) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:758) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:422) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355) at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:320) at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:132) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:678) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:703) at java.lang.Thread.run(Thread.java:811) Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:258) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1543) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:887) at org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99) at org.springframework.osgi.util.BundleDelegatingClassLoader.loadClass(BundleDelegatingClassLoader.java:156) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.springframework.util.ClassUtils.forName(ClassUtils.java:211) at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385) at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138) ... 13 more 2010-10-04 14:41:44,359 Spring executor 12 ERROR [extender.internal.activator.ContextLoaderListener] Application context refresh failed (NonValidatingOsgiBundleXmlApplicationContext(bundle=com.pyxis.greenhopper.jira, config=osgibundle:/META-INF/spring/*.xml)) org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.plugin.link.DefaultLinkProviderManager] for bean with name 'gh-linkProviderManager' defined in URL [bundle://42.0:1/com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1144) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:758) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:422) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355) at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:320) at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:132) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:678) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:703) at java.lang.Thread.run(Thread.java:811) Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:258) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1543) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:887) at org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99) at org.springframework.osgi.util.BundleDelegatingClassLoader.loadClass(BundleDelegatingClassLoader.java:156) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.springframework.util.ClassUtils.forName(ClassUtils.java:211) at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385) at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138) ... 13 more 2010-10-04 14:41:45,109 server.startup : 0 INFO [atlassian.plugin.manager.DefaultPluginManager] Plugin system started in 0:01:25.656 2010-10-04 14:41:45,890 server.startup : 0 INFO [atlassian.jira.startup.JiraStartupLogger] ___ Plugin System Started _________________ {code} The plugin is placed in the JIRA_HOME\plugins\installed-plugins directory, and the directory is added to the JVMs class path. JIRA is working, while the Greenhopper plugin is disabled. When I try enabling the plugin from the administration UI, I get the following message. {code} GreenHopper Description: Rich Management Client for JIRA (Build: #128546) Vendor: Atlassian Plugin Version: 5.3-beta3 JIRA Version: 4.2 Installation Mode: Managed There were errors loading this plugin: There was a problem loading the module descriptor: java.lang.Void.<br/>Unable to enable web fragment {code}
    via by Kris-Mikael Krister,
  • I start Roo 1.1RC1 with the roo.sh startup script and while I'm getting a prompt I'm getting a JDK-related error message (see below) indicating that perhaps org.springframework.roo.addon.gwt needs JDK6. This prevents me from using Roo 1.1RC on my developer machine. I'm not sure if I could circumvent the problem by unregistering the GWT-component, as I will not use it right now. I selected component Core as Roo doesn't survive this error and Roo keeps a "Please wait - still loading" message ad inifinitum if I try to use the other functions. Error message: 2010-okt-15 13:37:00 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.ServiceException: Service factory exception: Bad version number in .class file at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:310) at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:220) at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:322) at org.apache.felix.framework.Felix.getService(Felix.java:2913) at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:330) at org.apache.felix.scr.impl.manager.DependencyManager.getService(DependencyManager.java:761) at org.apache.felix.scr.impl.manager.DependencyManager$1.getInstance(DependencyManager.java:1003) at org.apache.felix.scr.impl.helper.BindMethod.getParameters(BindMethod.java:436) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:212) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.manager.DependencyManager.invokeBindMethod(DependencyManager.java:991) at org.apache.felix.scr.impl.manager.DependencyManager.serviceAdded(DependencyManager.java:305) at org.apache.felix.scr.impl.manager.DependencyManager.serviceChanged(DependencyManager.java:169) at org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:864) at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:732) at org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:662) at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:3619) at org.apache.felix.framework.Felix.access$000(Felix.java:39) at org.apache.felix.framework.Felix$2.serviceChanged(Felix.java:667) at org.apache.felix.framework.ServiceRegistry.registerService(ServiceRegistry.java:97) at org.apache.felix.framework.Felix.registerService(Felix.java:2760) at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:252) at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerService(AbstractComponentManager.java:408) at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerComponentService(AbstractComponentManager.java:419) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:1003) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2357) at java.lang.Class.getConstructor0(Class.java:2671) at java.lang.Class.newInstance0(Class.java:321) at java.lang.Class.newInstance(Class.java:303) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:183) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.DelayedComponentManager.createRealComponent(DelayedComponentManager.java:91) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Registered.getService(AbstractComponentManager.java:1139) at org.apache.felix.scr.impl.manager.DelayedComponentManager.getService(DelayedComponentManager.java:85) at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:306) ... 31 more 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] The activate method has thrown an exception java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at org.springframework.roo.addon.gwt.GwtMetadataProvider.getProvidesType(GwtMetadataProvider.java:206) at org.springframework.roo.addon.gwt.GwtMetadataProvider.activate(GwtMetadataProvider.java:194) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:592) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:213) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:138) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:991) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] Component instance could not be created, activation failed 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] The activate method has thrown an exception java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at org.springframework.roo.addon.gwt.GwtMetadataProvider.getProvidesType(GwtMetadataProvider.java:206) at org.springframework.roo.addon.gwt.GwtMetadataProvider.activate(GwtMetadataProvider.java:194) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) Please wait - still loading at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:592) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:213) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:138) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:991) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] Component instance could not be created, activation failed
    via by MiB,
  • I start Roo 1.1RC1 with the roo.sh startup script and while I'm getting a prompt I'm getting a JDK-related error message (see below) indicating that perhaps org.springframework.roo.addon.gwt needs JDK6. This prevents me from using Roo 1.1RC on my developer machine. I'm not sure if I could circumvent the problem by unregistering the GWT-component, as I will not use it right now. I selected component Core as Roo doesn't survive this error and Roo keeps a "Please wait - still loading" message ad inifinitum if I try to use the other functions. Error message: 2010-okt-15 13:37:00 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] FrameworkEvent ERROR org.apache.felix.log.LogException: org.osgi.framework.ServiceException: Service factory exception: Bad version number in .class file at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:310) at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:220) at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:322) at org.apache.felix.framework.Felix.getService(Felix.java:2913) at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:330) at org.apache.felix.scr.impl.manager.DependencyManager.getService(DependencyManager.java:761) at org.apache.felix.scr.impl.manager.DependencyManager$1.getInstance(DependencyManager.java:1003) at org.apache.felix.scr.impl.helper.BindMethod.getParameters(BindMethod.java:436) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:212) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.manager.DependencyManager.invokeBindMethod(DependencyManager.java:991) at org.apache.felix.scr.impl.manager.DependencyManager.serviceAdded(DependencyManager.java:305) at org.apache.felix.scr.impl.manager.DependencyManager.serviceChanged(DependencyManager.java:169) at org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:864) at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:732) at org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:662) at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:3619) at org.apache.felix.framework.Felix.access$000(Felix.java:39) at org.apache.felix.framework.Felix$2.serviceChanged(Felix.java:667) at org.apache.felix.framework.ServiceRegistry.registerService(ServiceRegistry.java:97) at org.apache.felix.framework.Felix.registerService(Felix.java:2760) at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:252) at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerService(AbstractComponentManager.java:408) at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerComponentService(AbstractComponentManager.java:419) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:1003) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2357) at java.lang.Class.getConstructor0(Class.java:2671) at java.lang.Class.newInstance0(Class.java:321) at java.lang.Class.newInstance(Class.java:303) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:183) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.DelayedComponentManager.createRealComponent(DelayedComponentManager.java:91) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Registered.getService(AbstractComponentManager.java:1139) at org.apache.felix.scr.impl.manager.DelayedComponentManager.getService(DelayedComponentManager.java:85) at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:306) ... 31 more 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] The activate method has thrown an exception java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at org.springframework.roo.addon.gwt.GwtMetadataProvider.getProvidesType(GwtMetadataProvider.java:206) at org.springframework.roo.addon.gwt.GwtMetadataProvider.activate(GwtMetadataProvider.java:194) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:592) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:213) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:138) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:991) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] Component instance could not be created, activation failed 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] The activate method has thrown an exception java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:676) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.searchpolicy.R4Wire.getClass(R4Wire.java:108) at org.apache.felix.framework.ModuleImpl.searchImports(ModuleImpl.java:1440) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:753) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:375) at org.springframework.roo.addon.gwt.GwtMetadataProvider.getProvidesType(GwtMetadataProvider.java:206) at org.springframework.roo.addon.gwt.GwtMetadataProvider.activate(GwtMetadataProvider.java:194) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) Please wait - still loading at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:592) at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:213) at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38) at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:542) at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:434) at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:138) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226) at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118) at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:991) at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298) at org.apache.felix.scr.impl.manager.AbstractComponentManager$3.doRun(AbstractComponentManager.java:505) at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67) at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96) at java.lang.Thread.run(Thread.java:613) 2010-okt-15 13:37:01 org.springframework.roo.felix.JdkDelegatingLogListener logNow ALLVARLIG: [org.springframework.roo.addon.gwt [18]] [org.springframework.roo.addon.gwt.GwtMetadataProvider] Component instance could not be created, activation failed
    via by MiB,
  • Support for JDK 1.7
    via GitHub by Emmerson-Miranda
    ,
  • Compatible?
    via by Dinesh,
    • org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.atlassian.greenhopper.plugin.link.DefaultLinkProviderManager] for bean with name 'gh-linkProviderManager' defined in URL [bundle://42.0:1/com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1144) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:524) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1177) at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:758) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:422) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:69) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:355) at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:320) at org.springframework.osgi.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:132) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:678) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:703) at java.lang.Thread.run(Thread.java:811) Caused by: java.lang.UnsupportedClassVersionError: (com/atlassian/greenhopper/plugin/link/DefaultLinkProviderManager) bad major version at offset=6 at java.lang.ClassLoader.defineClassImpl(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:258) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImpl.java:1872) at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:758) at org.apache.felix.framework.ModuleImpl.access$100(ModuleImpl.java:61) at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1733) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:674) at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1543) at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:887) at org.springframework.osgi.util.BundleDelegatingClassLoader.findClass(BundleDelegatingClassLoader.java:99) at org.springframework.osgi.util.BundleDelegatingClassLoader.loadClass(BundleDelegatingClassLoader.java:156) at java.lang.ClassLoader.loadClass(ClassLoader.java:597) at org.springframework.util.ClassUtils.forName(ClassUtils.java:211) at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:385) at org.springframework.beans.factory.support.AbstractBeanFactory.resolveBeanClass(AbstractBeanFactory.java:1138) ... 13 more

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    16 more bugmates