java.lang.RuntimeException

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Need help please
    via GitHub by Smull99
    ,
  • Need help please
    via GitHub by Smull99
    ,
  • GitHub comment 904#238532716
    via GitHub by ia7maxd
    ,
  • Bot wont start
    via GitHub by qwertychacha2002
    ,
  • GitHub comment 806#238089531
    via GitHub by zhoushifeng8
    ,
  • Error
    via GitHub by ramviknesh07
    ,
  • Login Problem
    via GitHub by Raven1994
    ,
    • java.lang.RuntimeException: java.net.BindException: Address already in use at io.undertow.Undertow.start(Undertow.java:186)[undertow-core-1.3.23.Final.jar!/:1.3.23.Final] at org.springframework.boot.context.embedded.undertow.UndertowEmbeddedServletContainer.start(UndertowEmbeddedServletContainer.java:121)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.startEmbeddedServletContainer(EmbeddedWebApplicationContext.java:293)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.finishRefresh(EmbeddedWebApplicationContext.java:141)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:541)[spring-context-4.2.7.RELEASE.jar!/:4.2.7.RELEASE] at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:118)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:760)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.SpringApplication.createAndRefreshContext(SpringApplication.java:360)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:306)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:1185)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:1174)[spring-boot-1.3.6.RELEASE.jar!/:1.3.6.RELEASE] at ink.abb.pogo.scraper.MainKt.main(Main.kt:71)[PokemonGoBot-0.5.0.jar!/:na] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[na:1.8.0_101] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[na:1.8.0_101] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[na:1.8.0_101] at java.lang.reflect.Method.invoke(Method.java:498)[na:1.8.0_101] at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:54)[PokemonGoBot-0.5.0.jar!/:na] at org.springframework.boot.loader.Launcher.launch(Launcher.java:104)[PokemonGoBot-0.5.0.jar:na] at org.springframework.boot.loader.Launcher.launch(Launcher.java:61)[PokemonGoBot-0.5.0.jar:na] at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:52)[PokemonGoBot-0.5.0.jar:na] Caused by: java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method)[na:1.8.0_101] at sun.nio.ch.Net.bind(Net.java:433)[na:1.8.0_101] at sun.nio.ch.Net.bind(Net.java:425)[na:1.8.0_101] at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)[na:1.8.0_101] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)[na:1.8.0_101] at org.xnio.nio.NioXnioWorker.createTcpConnectionServer(NioXnioWorker.java:190)[xnio-nio-3.3.6.Final.jar!/:3.3.6.Final] at org.xnio.XnioWorker.createStreamConnectionServer(XnioWorker.java:243)[xnio-api-3.3.6.Final.jar!/:3.3.6.Final] at io.undertow.Undertow.start(Undertow.java:142)[undertow-core-1.3.23.Final.jar!/:1.3.23.Final] ... 19 more

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    musketyrmusketyr
    9 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    nasimknasimk
    34 times, last one,
    MattyMatty
    1 times, last one,
    137 more bugmates