java.lang.UnsatisfiedLinkError: no jniopencv_core in java.library.path

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.


rafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • GitHub comment 35#238523866
    via GitHub by mridulZaloni
    ,
  • UnsatisfiedLinkError, thanks
    via GitHub by junyongyou
    ,
  • JavaCV project compile error
    via Stack Overflow by PeterOtto
    ,
  • Problem with jniopencv_core
    via GitHub by TheSuperPlayer
    ,
  • GitHub comment 178#223379647
    via GitHub by iamyellow
    ,
    • java.lang.UnsatisfiedLinkError: no jniopencv_core in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1886) at java.lang.Runtime.loadLibrary0(Runtime.java:849) at java.lang.System.loadLibrary(System.java:1088) at org.bytedeco.javacpp.Loader.loadLibrary(Loader.java:654) at org.bytedeco.javacpp.Loader.load(Loader.java:492) at org.bytedeco.javacpp.Loader.load(Loader.java:409) at org.bytedeco.javacpp.opencv_core.<clinit>(opencv_core.java:10) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:274) at org.bytedeco.javacpp.Loader.load(Loader.java:464) at org.bytedeco.javacpp.Loader.load(Loader.java:409) at org.bytedeco.javacpp.opencv_imgcodecs.<clinit>(opencv_imgcodecs.java:13) at com.mgohain.javaCV.assamese.CharRecognition.Train.Test.main(Test.java:24) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at com.intellij.rt.execution.application.AppMain.main(AppMain.java:144) Caused by: java.lang.UnsatisfiedLinkError: no opencv_imgproc310 in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1886) at java.lang.Runtime.loadLibrary0(Runtime.java:849) at java.lang.System.loadLibrary(System.java:1088) at org.bytedeco.javacpp.Loader.loadLibrary(Loader.java:654) at org.bytedeco.javacpp.Loader.load(Loader.java:483) ... 13 more

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    276 more bugmates