java.sql.SQLException

Error while reading binary stream: java.io.IOException: Pipe not connected

Samebug tips1

MySQL doesn't support some types of characters (such as emojis) with the utf8 encoding. You need to be on MySQL 5.5+ and force utf8mb4 (everywhere, client and server). You can do this sending the query "SET NAMES utf8mb4". Check this https://goo.gl/3E2qzg

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web11202

  • Error while reading binary stream: java.io.IOException: Pipe not connected
  • Error while reading binary stream: java.io.IOException: Pipe not connected
  • Error while reading binary stream: java.io.IOException: Pipe not connected
  • Stack trace

    • java.sql.SQLException: Error while reading binary stream: java.io.IOException: Pipe not connected at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:910) at com.mysql.jdbc.ServerPreparedStatement.storeStream(ServerPreparedStatement.java:2378) at com.mysql.jdbc.ServerPreparedStatement.serverLongData(ServerPreparedStatement.java:1295) at com.mysql.jdbc.ServerPreparedStatement.serverExecute(ServerPreparedStatement.java:1047) at com.mysql.jdbc.ServerPreparedStatement.executeInternal(ServerPreparedStatement.java:684) at com.mysql.jdbc.PreparedStatement.execute(PreparedStatement.java:768) at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:168) at org.apache.james.mailrepository.JDBCMailRepository.store(JDBCMailRepository.java:743) at org.apache.james.mailrepository.JDBCSpoolRepository.store(JDBCSpoolRepository.java:236) at org.apache.james.transport.mailets.RemoteDelivery.service(RemoteDelivery.java:1001) at org.apache.james.transport.LinearProcessor.service(LinearProcessor.java:414) at org.apache.james.transport.JamesSpoolManager.process(JamesSpoolManager.java:397) at org.apache.james.transport.JamesSpoolManager.run(JamesSpoolManager.java:306) at java.lang.Thread.run(Thread.java:595)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 2 months ago
    11 times, 7 months ago
    Unknown user
    Once, 7 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    148 more bugmates