java.lang.NullPointerException

Exception #2539560

Samebug tips0

There are no available Samebug tips.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web6

  • via GitHub by itandetnik
    ,
  • via GitHub by melvinzhang
    ,
  • via GitHub by itandetnik
    ,
  • Stack trace

    • java.lang.NullPointerException at magic.model.event.MagicSourceManaActivation.canProduce(MagicSourceManaActivation.java:51) at magic.model.choice.MagicPayManaCostResultBuilder.build(MagicPayManaCostResultBuilder.java:62) at magic.model.choice.MagicPayManaCostResultBuilder.build(MagicPayManaCostResultBuilder.java:127) at magic.model.choice.MagicPayManaCostResultBuilder.build(MagicPayManaCostResultBuilder.java:127) at magic.model.choice.MagicPayManaCostResultBuilder.hasResults(MagicPayManaCostResultBuilder.java:157) at magic.model.condition.MagicManaCostCondition.accept(MagicManaCostCondition.java:28) at magic.model.event.MagicPayManaCostEvent.isSatisfied(MagicPayManaCostEvent.java:47) at magic.model.event.MagicActivation.canPlay(MagicActivation.java:108) at magic.model.event.MagicSourceActivation.canPlay(MagicSourceActivation.java:26) at magic.model.choice.MagicPlayChoice.addValidChoices(MagicPlayChoice.java:78) at magic.model.choice.MagicPlayChoice.getArtificialOptions(MagicPlayChoice.java:68) at magic.model.choice.MagicChoice.getArtificialChoiceResults(MagicChoice.java:97) at magic.model.choice.MagicChoice.getSimulationChoiceResult(MagicChoice.java:114) at magic.model.event.MagicEvent.getSimulationChoiceResult(MagicEvent.java:443) at magic.ai.MCTSAI.runSimulation(MCTSAI.java:483) at magic.ai.MCTSAI.randomPlay(MCTSAI.java:446) at magic.ai.MCTSAI.access$000(MCTSAI.java:65) at magic.ai.MCTSAI$2.run(MCTSAI.java:188) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    No Bugmate found.