org.elasticsearch.client.transport.NoNodeAvailableException

None of the configured nodes are available: [{#transport#-1}{3CJj2k77QF20-9Qw-PZlzA}{10.114.20.230}{10.114.20.230:9300}, {#transport#-2}{1hVLh7CIQY2DkEL_YcUnHA}{10.114.20.230}{10.114.20.230:9300}]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web194

  • None of the configured nodes are available: [{#transport#-1}{3CJj2k77QF20-9Qw-PZlzA}{10.114.20.230}{10.114.20.230:9300}, {#transport#-2}{1hVLh7CIQY2DkEL_YcUnHA}{10.114.20.230}{10.114.20.230:9300}]
  • None of the configured nodes are available: [{#transport#-1}{****}{****/****:9300}]
  • None of the configured nodes are available: [{#transport#-1}{XTdOuK_fR62aQVbI3MrpkQ}{localhost}{127.0.0.1:9300}] NoNodeAvailableException[None of the configured nodes are available: [{#transport#-1}{XTdOuK_fR62aQVbI3MrpkQ}{localhost}{127.0.0.1:9300}]]
  • Stack trace

    • org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{3CJj2k77QF20-9Qw-PZlzA}{10.114.20.230}{10.114.20.230:9300}, {#transport#-2}{1hVLh7CIQY2DkEL_YcUnHA}{10.114.20.230}{10.114.20.230:9300}] at org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:314)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:228)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.client.transport.support.TransportProxyClient.execute(TransportProxyClient.java:63)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.client.transport.TransportClient.doExecute(TransportClient.java:319)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:403)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:80)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:54)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5] at org.elasticsearch.action.ActionRequestBuilder.get(ActionRequestBuilder.java:62)[elasticsearch-5.0.0-alpha5.jar:5.0.0-alpha5]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 1 week ago
    30 times, 6 months ago
    2 times, 9 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    17 more bugmates