java.lang.IllegalStateException

Could not find backup for factory javax.faces.application.ApplicationFactory.

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web19532

  • via JBoss Issue Tracker by Erick de Oliveira Leal, 1 year ago
    Could not find backup for factory javax.faces.application.ApplicationFactory.
  • Could not find backup for factory javax.faces.application.ApplicationFactory.
  • Could not find backup for factory javax.faces.application.ApplicationFactory.
  • Stack trace

    • java.lang.IllegalStateException: Could not find backup for factory javax.faces.application.ApplicationFactory. at javax.faces.FactoryFinder$FactoryManager.getFactory(FactoryFinder.java:1010)[jsf-api-2.1.21.jar:2.1] at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:342)[jsf-api-2.1.21.jar:2.1] at com.sun.faces.config.InitFacesContext.getApplication(InitFacesContext.java:141)[jsf-impl-2.1.21.jar:2.1.21] at com.sun.faces.config.ConfigureListener.contextDestroyed(ConfigureListener.java:314)[jsf-impl-2.1.21.jar:2.1.21] at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:3427)[jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1] at org.apache.catalina.core.StandardContext.stop(StandardContext.java:3920)[jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1] at org.apache.catalina.core.StandardContext.start(StandardContext.java:3839)[jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1] at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:156)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[rt.jar:1.7.0_40] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[rt.jar:1.7.0_40] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[rt.jar:1.7.0_40] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[rt.jar:1.7.0_40] at java.lang.Thread.run(Thread.java:724)[rt.jar:1.7.0_40] at org.jboss.threads.JBossThread.run(JBossThread.java:122)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    2 times, 3 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    2 times, 1 year ago
    Unknown user
    Once, 1 year ago
    17 more bugmates