com.liferay.cdi.portlet.bridge.CDIContextListener

java.lang.NoClassDefFoundError: javax/enterprise/inject/spi/BeanManager

Samebug tips1

Check if the version of resteasy is using is the same JBoss is using. To find it out, search for resteasy-jaxrs* in JBoss/Wildfly directory and at your pom.xml.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web7

  • via liferay.com by Unknown author, 1 year ago
    java.lang.NoClassDefFoundError: javax/enterprise/inject/spi/BeanManager
  • via liferay.com by Unknown author, 11 months ago
    java.lang.NoClassDefFoundError: javax/enterprise/inject/spi/BeanManager
  • via liferay.com by Unknown author, 1 year ago
    java.lang.NoClassDefFoundError: javax/enterprise/inject/spi/BeanManager
  • Stack trace

    • com.liferay.cdi.portlet.bridge.CDIContextListener: java.lang.NoClassDefFoundError: javax/enterprise/inject/spi/BeanManager at com.liferay.cdi.portlet.bridge.CDIContextListener.contextInitialized(CDIContextListener.java:45)[cdi-portlet-bridge-shared-6.2.0.2-SNAPSHOT.jar:] at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3339)[jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1] at org.apache.catalina.core.StandardContext.start(StandardContext.java:3777)[jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1] at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:156)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:60)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:93)[jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[rt.jar:1.7.0_40] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[rt.jar:1.7.0_40] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[rt.jar:1.7.0_40] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[rt.jar:1.7.0_40] at java.lang.Thread.run(Thread.java:724)[rt.jar:1.7.0_40] at org.jboss.threads.JBossThread.run(JBossThread.java:122) Caused by: java.lang.ClassNotFoundException: javax.enterprise.inject.spi.BeanManager from [Module "deployment.jsf2-cdi-portlet.war:main" from Service Module Loader] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:196)[jboss-modules.jar:1.2.0.Final-redhat-1] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444)[jboss-modules.jar:1.2.0.Final-redhat-1] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432)[jboss-modules.jar:1.2.0.Final-redhat-1] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374)[jboss-modules.jar:1.2.0.Final-redhat-1] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119)[jboss-modules.jar:1.2.0.Final-redhat-1] ... 12 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    3 times, 1 year ago
    Once, 1 month ago
    Once, 1 month ago
    2 times, 6 months ago
    81 more bugmates